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Preface

This guide details the DIGITAL Remote Server Manager (RSM)
application.  The documentation details how a network professional can
use RSM to manage geographically dispersed servers.

The guide begins where the Remote Server Manager Installation Guide
left off.   After a brief introduction to the DIGITAL Remote Server
Manager, the chapters that follow detail the routine use of the RSM
application on your computer to create a management station.  Details
on enhanced configuration – beyond the default settings, and advanced
usage, and troubleshooting follow.

• Chapter1 gives you an overview of RSM.

• Chapter 2 details the routine management performed at the
management station.

• Chapter 3 steps through more advanced capabilities and problem
solving.

• Chapter 4 sets up security.

• Chapter 5 reviews the menus and options on the application.

• Chapter 6 takes you into the world of the hybrid RSM – explaining
how you can create your own scripts to monitor beyond the basics.

• Appendixes A, B and C contain guides to troubleshooting,
configuration files, and paging setup.

 

 The DIGITAL Remote Server Manager Installation Guide, supplied with
the RSM hardware kit is also available.  This manual covers the
installation and default configuration process for the RSM controller.
Please refer to this installation manual for detailed information on
installing the RSM controller into the remote server.
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 Before You Start
 This guide assumes you are familiar with the:

• Operational requirements of managing a network

• Unique requirements of monitoring and maintaining remote servers

• Planning, implementation, and troubleshooting applicable in
communications components such as telephone line/modem
communications

• Windows NT operating system and the System Configuration Utility
(SCU)

 Terminology
 The following technical terms are used in this manual.

Term Definition

Remote Server
Manager

Also called RSM. RSM consists of an integrated
hardware & software product.

Management
Station

A PC server with Windows NT V3.51 and RSM
software installed.  It enables a system manager to
access remote servers.

Controller The RSM hardware module installed in a remote
server.  The controller monitors the server even if
the server is not functioning provided that the
remote power feature is installed

Remote Server The remote server being monitored by the
management station
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 Keyboard Conventions
 The following keyboard conventions are used by RSM.

To Do Press These Keys

Scroll one window up or down PAGE UP, PAGE DOWN

Go to the beginning of the list CTRL, HOME

Go to the end of the list CTRL, END

Move focus left or right LEFT or RIGHT ARROW

Move focus one line up or down UP, DOWN ARROW

Move to next window CTRL, TAB

Move to previous window CTRL, SHIFT, TAB

Go to the next field DOWN ARROW or TAB

Go to the previous field UP ARROW, SHIFT, TAB

Go to the next Group CTRL+DOWN ARROW

Go to the previous Group CTRL+UP ARROW

Display Help F1

Display Help
(from a Console window)

CTRL+ALT+F1

 Related Documentation
 The following documents are shipped with RSM:

• DIGITAL Remote Server Manager Installation Guide

• DIGITAL Remote Server Manager Management Station Software
User's Guide
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Introduction 1
 The DIGITAL Remote Server Manager (RSM) is a combined hardware
and software solution which provides easy, quick, and cost effective
support for a remote server.

 RSM manages your DIGITAL servers using RS232 connectivity either
directly or over a phone line using a modem.  The product consists of:

• RSM EISA controller and initialization files for the remote server

• Management station software for the local Microsoft Windows NT
computer.

 RSM can monitor a remote server or actually take control of a server
(even when the server is not powered on).  The server can be at a
different geographic location or at the same location as the management
station.

 RSM saves money, time, and effort by centralizing the management of
your remote servers, reducing the need to dispatch expensive expertise to
a remote site.
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 RSM Features
 The RSM management station kit  (part number QB-38EAA-SA)
contains software media and documentation for remotely managing a
DIGITAL X86 processor-based server from a management station
running Microsoft’s Windows NT operating system.

 Feature  Description

 Secure access  Access is limited by passwords and
dialback to authorized users.

 Alarm Notification  Alarms can be set to occur on: out-of-
range voltage values, temperature values,
server status, and power failures.

 Automated alarm
response

 An alarm can be set up to initiate a chain
of actions such as dialing a pager or
shutting down the system.

 Status Reports  Export environmental data to a log file.

 Event Log  Historical status data to use for trending
and troubleshooting.

 Remote Server Control  Servers can be booted/upgraded or
configured from the management station.

 Upload/Download files  Update files such as SCU configuration,
CMOS setup, and RSM files.
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 Remote Server Control
 RSM enables the management station to:

• Reset a remote server as if the server's reset button was pressed.  The
reset cable must be connected between the controller and the
server’s main logic board to reset a remote server.

• Boot a remote server as if CTL+ALT+DELETE was pressed twice

• Powers on or powers off1 the remote server's power as if the server's
power switch was turned on or off.

 Event alert Notifications
 The controller, located in the remote server, operates independently of
the remote server it is installed into.  It monitors environmental
conditions previously specified and records any normal and/or out of
range readings.  It can send an event alert message to the management
station or issue a page if the remote server loses power, or stops
functioning.   Conditions being monitored include:

• Temperature and temperature change

• Power supply voltage levels

• Server mode

• Power-On Self-Test (POST) code

• Number of keystrokes since the last reset
 
 An event (an alert) occurs when a server condition exceeds a limit
defined in the events file.  When an event occurs, RSM can record the
server’s condition in non-volatile memory to be sent later to the
management station server log, or it can send an alert to the
management station directly (default), or to a pager.  The events file can
be customized for the server environment, or the default file can be used.

                                                       

 1 The power On/Off function can only be done on servers that support it.  This function
cannot be done on an XL5 server.
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 Security
 RSM uses Windows NT security as the foundation to its own
management station security.  Windows NT requires a password to log
in.  Only authorized personnel should have a Windows NT account on a
management station.  The security of a management station and access
to managed servers depends on secure password administration.

 RSM security features provide system managers with the choice of
implementing or not implementing security during connection to the
remote servers.

 Remote Server Control/Remote Console Access
 If the remote server has a ISA VGA adapter with monitor, and a non-

windows enhanced keyboard, you can also use your management station
as a remote console.  Remote access to the remote server’s console and
keyboard allows the management station to appear as if its monitor and
keyboard are connected to the remote server.  This is further detailed in
Chapter 3, Using a Management Station as a Remote Console.

 Remote Maintenance
 Remote maintenance can be performed through the management
station’s diskette drives.  The types of maintenance include:

• Boot the server from a diagnostic diskette in the management
station

• Use a diskette or a diskette-image file on the management station as
a server diskette

 
 Diagnostics can also be simultaneously booted on multiple remote
servers using a diskette image file.

 File Transfers
 RSM allows file transfers between the management station and the
remote server.  Files commonly transferred include: CMOS setup, EISA
configuration, RSM firmware, Extended BIOS, server keystroke log, and
customized RSM files (events, macros, scripts, and security).
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 RSM Kits
 The following RSM kits are available.

Option Description Part Number

 Hardware  Remote Server Manager
Hardware

 FR-PCDSC-AA

 Software  Remote Server Manager
Software

 QB-38EAA-SA

 Package  Remote Server Manager
Package (hardware and
software)

 FR-PCDSM-AA

 Serial Reset
Cable

 Server reset cable  FR-PCXCK-AF

 Modem  56Kbps external modem  FR-PCXDF-XX

 Other  Video Card  FR-PCXAG-BC
 

 RSM Options

 Modem/Multiplexor Support
 DIGITAL has tested and verified specific support products such as
modems and multiplexors for interoperability, performance, and ease of
use with RSM.  Details on the installation and support of modems and
multiplexors can be found in the Remote Server Manager Installation
Guide.

 

 NOTE: DIGITAL provides modem script files for a select number of
modems.  If the modem you are using is not one of the supported
modems, it will need to be customized.

 DIGITAL Support and Warranty
 Refer to the separate warranty information that comes with the RSM
solution for detailed information on DIGITAL Remote Server
Manager software warranty. Call 1-800-DIGITAL for assistance.
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Routine Management Activities 2
This chapter details the routine workings of the RSM.  It details the
basic management routines performed at the management station
console.   It reviews the following activities:

• Starting RSM on the management station

• Adding remote servers

• Connecting to the remote servers

• Setting system preferences

• Receiving event alerts

• Viewing and saving status information

The Remote Server Manager Installation Guide details the default
settings and initial configuration of the RSM Management Station and
Remote Server connections.
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Overview
The management station consists of the RSM software interface and the
port manager event alert window.  The port manager posts event alerts:
messages from the remote servers about their health and well being.  The
messages are received via a modem transmission from the remote server.

The Remote Server Manager user interface on the management station is
used to add remote server information, change the information values
being requested from the remote servers, and to gain access to these
servers.
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Starting RSM on the Management Station
If your management server is dedicated only to the RSM function, place
the port manager and the RSM management station icons in your
Startup folder.  The port manager will then automatically display each
time you log into the management station.   Otherwise complete the
following to start the RSM application:

1. Choose the RSM group icon from the Windows NT Program
Manager.  The RSM program group window displays.

2. Double click the RSM icon. The RSM window displays.

3. Select the Remote Server Manager console icon.  RSM opens the
management station application.

The first time you start up a management station, or any time RSM has
no servers set up, a dialog box displays.  Select OK or press Enter to
continue to start RSM.

If the Port Manager has difficulty setting up the modem or if a port
connection fails, the name of the specific communication port that failed
displays as follows:

Link Manager on port Com1 has terminated

RSM will not use this communication port again until you restart the
port manager.

RSM will display the Select window (Figure 2-1).  The Select window
displays basic information about each server. If this is the first time RSM
is being used, the Select window lists only a default server, “server_1”
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Figure 2-1 Select Window

NOTE: If the Port Manager is not running, then event alerts cannot be
received by the management station.
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Adding Remote Servers
Use the Setup window to enter basic information about the remote
server, such as its name and attributes, its connection parameters, and
default file names for transfers. The Setup window also allows you to
make changes to existing servers.

The installation guide has walked you through setting up at least one
remote server connection to the management station, here we will review
adding more remote servers and modifying settings to meet your needs.
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Adding a New Server
To add servers, access the setup window.

1. Click on the Function menu list and choose Setup_New.

Figure 2-2 Setup Window
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The following minimum information is required to add a server:

1. Specify the name of the server in the Server Names and Attributes
window.

2. Add the following connection actions:

• Management station telephone number

• Include = dial

• Save the information

After the server information is saved, the server’s name is displayed in
the Select window.  When setting up the remote servers, begin by using
the default configuration files that currently exist on the RSM remote
server and management station.  If the servers you are adding require
settings other than the default, see Script Files in Chapter 6 on creating
scripts and customizing the RSM setup.
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Passively Upgrading Server Firmware
If you are upgrading your RSM, and the firmware on the RSM controller
is older than the current shipped version, the RSM application
automatically updates the firmware during the first connection.

When making a connection, RSM checks the controller installed in the
remote server.  If either the controller firmware version and revision
number or its EBIOS version in the remote server is older than the
currently installed version of RSM in the management station, a dialog
box displays.  You have the option to upgrade the controller firmware
and/or EBIOS from the management station's executable directory
through this box.  In some instances, the firmware must be upgraded
before continuing.  To start the upgrade process:

1. Choose OK. RSM downloads and reboots the controller firmware,
reconnects the controller to the server, and downloads the new
EBIOS, if needed.

2. Choose Cancel when complete.

If you choose to upgrade, be sure to complete the operation before
cycling power on the controller.  If power is lost, the controller can be in
an unusable state when repowered.  Should the connection fail during an
upgrade operation, it can be completed upon a subsequent connection as
long as power outage on the controller has not occurred.  See Chapter 3,
Setting the Extended BIOS Address.

Modifying Existing Servers
To edit server names:

1. Select a server name on a Select window.

2. Select Setup from the Select window.  Move the mouse pointer to the
Setup button and click, or select Function from the menu bar and
select Edit Setup from the Function pull-down menu.
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Entering Remote Server Information
To enter information into the Remote Server Manager application:

1. Select Setup from the Select window. The Setup window displays.

2. Enter the appropriate information in each field.  Table 2-1 explains
the fields found in the Server Names and Attributes, Connection
Actions and Defaults for File Transfers windows.

Figure 2-3 Entering Remote Server Information
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Table 2-1 Setup Field Descriptions

Field Description

Server Name The unique server name for each remote server.  The server can be up
to eight characters long and is used to associate any particular events
and event alerts with the server. If you enter a duplicate server name,
RSM displays an error message.   RSM is case-sensitive, use lower
case for best results.

Description This field is optional.  The description must be less than 64
characters.  If you enter a duplicate description, RSM displays an
error message.

Default Console VGA

Time Zone Time Zone indicates the remote server’s time zone.  The default is the
management station’s time zone. The value is entered using the
Preferences window..  If nothing is entered manually the field appears
blank. The field can also be user-defined.

NOTE: If there is a problem keeping current time between the server
and management station in different time zones when running on a
Windows NT system, use the standard zone instead of the Windows
NT expanded time zone names (Lima, Peru, vs. Eastern use Eastern).

System Type Choose the type of server being managed.  The default server types
are: Intel Server: Full RSM functionality.

XL Server 466: Full RSM functionality, except for cold boot.

Server Attribute
Value

Up to 30 characters.  You can leave this field blank.  A Server
Attribute Name displays if previously entered on the Preferences
window.

Connection
Actions

Select the new action pull down menu. Select the telephone number
followed by the include or script options.
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Modifying Connection Actions
Connection actions are an ordered list of actions that RSM uses to
connect to a remote server.  A default set of actions are included in
the window.  Additional actions and user defined actions can also be
entered.  Chapter 6 details scripting and creating customized
connection actions.

The connection window is blank when doing a direct connect to a
new server.

Figure 2-4 Connection Window
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Entering Connection Action Information

RSM provides the following connection actions:

1. Select <new action> for the Connection Actions pull-down menu
display.  Select a connection action.

2. Select a value from the Connection Action pull-down menu or enter
the appropriate information (file name or value as required) and
press Tab.

Table 2-2 Connection Actions

Connection Action Description

Include Executes a macro from the default Macros file (default.mcr)
that defines a set of connection actions.  Enter a macro name to
identify the macro.

Port The Port pull-down menu lists the ports that RSM can use and
also lists Auto.  Auto allows RSM to let the Port Manager
choose the next available originating port (Auto =default).

Retry Automatically attempts to connect a failed connection for the
number of iterations specified.

Script A line in a script file consisting of a dialog of messages to send
and expected responses.  Enter a name to identify the line
references.

Speed Displays the serial port baud rates for modem to port
connection. Values are:  300, 1200, 2400, 4800, 9600, 14400,
19200, 38400, and 57600 (2400=default).

Telephone The telephone number of the management station, plus optional
special characters.  In most cases, only the telephone number
displays.  Special characters can be included to specify extra
features, such as pauses, selecting pulse or tone dialing.  The
telephone number must include all digits needed to reach the
management station through a telephone line.
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Adding a New Connection Action
To select a new connection action from the existing list:

1. Select the line where you want to place the new connection action
name.

2. Select the Insert button.  The selected line moves down one line.

3. Enter the new Connection Action name.

Deleting a Connection Action
To delete a connection action from the existing list:

1. Select the connection action name you want to delete.

2. Select the Delete button.

Reordering the Connection Actions
To re-order the current connection actions:

1. Select a connection action from the list.

2. Select either the up arrow or the down arrow.   The up arrow moves
the selected item one line toward the top of the list each time you
select it.  The down arrow moves selected item one line toward the
bottom of the list.

3. Use the arrow key until the item is placed in the desired sequence.
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Defining Multiple Servers
The four setup buttons in the Another Setup window enable you to
define multiple servers quickly.  By using the Copy, Next, and
Previous buttons you can change the current information for use
with the new servers with any of the same or similar parameters.

Button Description

New Clears all fields in the current Setup window so that
you can enter information to define a new server.

Copy Copies all fields except for Short Name in the
current Setup window and creates a new Setup
window.  Copy is a quick way to set up multiple
servers and define identical default file names for
transfers between your management station and
multiple servers.  It is available when information is
in the Setup window.

Next Opens a Setup window for the next selected server.
Next is available when you have selected multiple
servers in the Setup window and there is another
server in the selected set that follows.

Previous Opens a Setup window for the previously selected
server.  Previous is available when you have selected
multiple servers and there is another server in the
selected set that precedes the current server.
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Connecting to a Remote Server
Connect the management station to a remote server by pressing the
Connect button in the server’s control window.

1. Highlight a server name in the Select window.

 Figure 2-5 Selecting a Server

 

2. Click the Control button.   The Control window for the highlighted
server displays.

3. Select Connect from the Control window.

NOTE: Do not double-click the Connect button.  This button changes to
Abort during the connection process, and the second click would end the
connection process.
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Figure 2-6 Control Window

NOTE: If the firmware on the controller is an older version than what is
on the management station, the RSM application automatically updates
the firmware during the first connection.  RSM transfers the new
firmware files and reboots the remote server.  The connection is lost to
that remote server. Reconnect to the remote server.

The remote server is now available for interaction.
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Connecting to Multiple Servers
To connect to multiple servers, repeat the process to a server or select
multiple servers before selecting Control.

RSM does not limit the number of remote servers to which you can
connect.  The management station's CPU and resources do impose a
limit on the maximum number of simultaneous connections.
Management station resources that limit telephone connections include
the number of telephone lines, RSM serial ports and/or multiplexors, and
modems.  All resources are dedicated to RSM when a connection is
active or if the phone line is being used for dialing back to the
management station when an event alert occurs.

RSM waits for an available serial port if one is not immediately
available.  This is indicated by the word "Pending", which displays in
the Select window Session pane.

Setting Status and Event Preferences
Once you have setup all the remote servers, you may change
management station defaults to reflect your individual preferences using
the Preferences command on the Options menu.   Specific Preferences
include Celsius or Fahrenheit as the temperature scale, user information,
Server Attribute Names, as well as other application-wide settings.
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Changing User Settings
The Preferences window enables you to view and change management
station settings such as temperature display, and connect and disconnect
on actions.   To open the Preferences window:

1. Select Options from the menu bar. The Options pull-down menu
displays.

2. Select Preferences from the Options pull-down menu.  The
Preferences window displays.

Figure 2-7 Preferences Window
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Entering User Information
User information is entered only when using RSM security.  See
Chapter 4 for more details on using security with RSM.

1. Enter the user name.  The User Name can be up to 20 characters.

2. Enter a password for the user, then press Enter.  A password is
required if the server Security file uses password to access the
controller.  The password can contain up to 12 characters.  An
asterisk displays for each password character entered.

3. A Confirm Password dialog box displays.  Enter the password again.

NOTE: Since the foundation of RSM security is Windows NT security, be
sure to utilize secure password administration and Windows NT security
procedures to safeguard your RSM user password.

Server Attribute Names
A server attribute is a word supplied by the user to group remote servers
by different characteristics. Server attributes can be used with the filter
option to limit the displayed servers in the Select window only those that
meet selected criteria.  It is used as a filter keyword when you are
looking for specific groupings of remote servers, such as all those on the
west coast, or all the DIGITAL Server 5000 series, for example.

You can define an unlimited number of server attributes names.  Each
name can have up to 8 characters. The name displays in a scrollable list
in the Setup window Server Names and Attributes pane.

Inserting a Server Attribute Name into an Existing List
To add new attributes:

1. Select the line before the one where the new entry is to appear.

2. Select Insert.  The line you selected moves down one line.

3. Enter the additional server attribute name.
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Deleting a Server Attribute Name

To delete a server attribute:

1. Select a server attribute name.

2. Select Delete.

Changing Options
Change an Options field value by selecting and clicking on the fields
display.  Either an X (Off) or a check mark ü(On), and F (Fahrenheit)
or a C (Celsius) are in the field.  Table 2-3 lists the Preferences options

Table 2-3 : Preference Options

Field Description

Temperature Scale Displays the temperature scale in Celsius or Fahrenheit.
Default = Celsius

Confirm All Deletions Displays a dialog box to confirm a server deletion.

Connect on Open Control Automatically connects to a server when Control window
opens and it is not already connected.  Default = automatic
connect.

Disconnect on Control
Close

Automatically disconnects server connections when you
close a Control window.  This option will not disconnect
any servers with activities, such as transfers still in
progress).  Default = automatic disconnect.

Open Console on Connect Automatically opens Console window after selecting
Connect button.  Default = not open window.

Save Windows Layout Saves the selected window arrangement after you quit
RSM. Default = on.

Newline> Tab Allows you to use the ENTER key to advance to the next
field. Default = on.
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Saving Server Information
Use the Save button at the bottom of the window to save any information
you entered or changed on the Setup window so that RSM can use it to
access and manage the remote server.

The three Setup buttons located at the bottom of the Setup window
enable you to save or discard changes and close the Setup window.

Save Saves changes made to Setup fields.  If the server Short
Name already exists, an error message displays and you
must enter a unique Short Name before you can save the
Setup information.  If the server's Long Name already
exists, an informational message appears for confirmation,
but you can still save the setup information.  Save is
available if you made any changes.

Cancel Closes the Setup window.  If you have made any changes,
RSM asks whether you want to save or discard the
changes before closing the Setup window.  Cancel is
always available.

OK Saves changes made to setup fields and closes the Setup
window.  OK is always available.

To save the server information:

1. Select OK if you did not change any server information.

2. To save changes, click on Save, then select OK.
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Receiving Event Alerts
Event alerts are received through the port manager window. DIGITAL
recommends keeping the port manager running to receive event alerts at
the management station.  If the controller places a call from the remote
server to the management station and the call does not complete for any
reason (the management station is not powered on, the telephone is
currently in use, the port manager is not running), the management
station will not receive that event alert notification.   

To avoid this, set up a log file in the RSM NVRAM server log entry so
that the entry is added to the server log when a connection is established
with the server. Reviewing Remote Server Status Log Event, later in this
chapter, details how to create this log.

Event alert actions at the remote server configuration setup can also be
defined to dialback to the management server multiple times or dial
multiple management station ports.  If the management station has
multiple modem ports, use alternative telephone numbers.

Reviewing Remote Server Status Log
The remote server status information can be viewed online and in a file
format. You can view server status from the Status window.  The Status
window displays a server log, environmental sensors, and system status.
The title bar displays the name of the server with its connection status.

Status and Event Information
Information supplied by the controller includes:

• Status of the server ; including environmental

• Power On Self Test (POST) results

• Status of keyboard cable connection (if applicable)

• Keystrokes (if keyboard is connected through the controller)

• Firmware version
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Online Status Information
Status information can be viewed for each individual remote server by
highlighting a remote server in the Select window and then pressing the
View Status button on the RSM Management station.

1. Highlight the server name in the Select window.

Figure 2-8 Select a Server

NOTE: A quick way to view status on several servers is to press SHIFT
key and select multiple servers.  Double-click the mouse with the
pointer on the servers.  This adds the servers to the set and opens a
Status window for each selected server.
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2.  Select View Status.  The Status window displays.

Figure 2-9 Status Window

The values shown in the Status window reflect the selected remote server
status as of the last update when connected.  The controller checks the
remote server's internal and external conditions every five seconds.
RSM updates the Status window when:

• The management station connects to a server

• Information changes in the Environment Sensors and the Server
System Status windows, if the management station is connected to
the server

• The management station receives an event alert

• You press the update button
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 Connection Status
 The Connection Status information is available in the Controller
window in the Connection Status pane.

 Figure 2-10 Connection Status Detail Pane

 

 

 Although you cannot modify these messages, you can select and copy
them to the clipboard for later use.
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 Connection Status Messages

Message Meaning

 Connection successfully
established

 Successful connection.

 Connection failed due to:  xxx:  Connection fails.   xxx lists
the reason for the failure.
Most failures result from a
time-out or carrier failure.
Just before a failure message
displays, a statement from the
Connection script displays
explaining where the
connection failed.

 Connected  or Not Connected  Connection results for the
selected server while in the
Setup, Status, Control,
Console, or Transfers
window.

 Server Log
 The Server Log keeps a history of event alerts received and updates
from the server NVRAM event log.  Log entries display in
chronological order starting with the most recent entry.  All log
entries that existed prior to opening the Status window, except event
alerts, display in black text; new log entries that occur while the
Status window is open display in blue text.  Event alerts always
display in red text.  An event alert displays in the server log when it
arrives at the management station.
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 To display fields that are not visible, such as Tag and Source, select
the right arrow on the horizontal scroll bar.  The following
information displays:

Message Meaning

 Time of Event  Time and date the server log entry occurred.

 Parameter  An internal or external condition that the
controller monitors.

 Test  Comparison between two values.  If two numbers
are compared, the result is consistent with
standard math sage. For example, -1V is greater
than -12V.

 Test                   Meaning

 []                         Inside

 ][                        Outside

 >                      Greater than

 <                         Less than

 Limit  Value that was compared.

 Value  Actual value of the sensor at the time of the
server log entry.

 Tag  A user-defined category that can be used to
organize log information in any way that
facilitates effective server management.

 Source  The source for the server log entry.  Currently,
the controller event monitor generates all server
log entries.

 .
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 Keystroke Log Display
 The Keystroke Log displays the typed keys as follows:

• Normal alphanumeric characters applied with Shift and CAPS as
they are typed.

• The CTRL+ALT, and/or Shift keys will display as bracketed
 <CTL->, <ALT->, and/or <SHF->accordingly. For example, If you
press the Ctrl + ALT+DEL keys, they will display in the Keystroke
Log as:

 <CTRL-ALT-DEL>

• Press Shift and any key. They display as follows:
 <SHF-F1>   (SHIFT + F1)

• The CAPS LOCK key displays as CAPS-ON or CAPS-OFF.  The
remaining entries will reflect the positions of the U.S. 101 keyboard.

NOTE: The keystroke log is only available if the keyboard is routed
through the RSM controller.  Not all keyboards will have this functionality.
See your Remote Server Manager Installation Guide for additional details.

Using Server Log Entries in Other Applications

You can copy, export, and print any part or all of the server log.

• Choose Copy from the Edit pull-down menu to copy to a file for
printing.

 Or

• Press Export or Print commands from the File pull-down menu.
Refer to the Exporting and Printing Status section later in this
chapter for more information.
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Environment Sensors
The Environment Sensors window on the Status window displays a
server's status at the time of the most recent update.

Figure 2-11  Environment Sensors Pane

Field Description

Temperature The default display is in Celsius. Change the
scale using the Preferences command in the
Options menu.

Temperature
change:

The controller monitors the average
temperature during the last four hours by
sampling the temperature every five minutes.
The average is compared with the current
reading to get a positive or negative difference
that displays in this field and can also be used
in an event definition.

Voltages:   +5V, +12V, -5V, -12V, 3.3V, and the
controller's external power supply.
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Server System Status
The Server System Status window displays system status as follows.

Figure 2-12  Server System Status Pane

Table 2-4 explains the fields in the Server System Status window.

Table 2-4 Server System Status

Server System Status Description

Server Mode Displays the possible server modes in the Server Mode
table that follows this table.

POST (Power On Self Test)
Result

Displays a server-specific three-digit code.  00 indicates the
results of the BIOS POST power-on self-test.  A failed self-
test is indicated by a value that represents the reason for
the failure.  See your server documentation for an
explanation of the values.

Keyboard Status Displays all possible keyboard status values.

Keystrokes Displays the number of keystrokes since the last system
reset.

Software Version The controller's software version is the number that
precedes the colon.  The sequence (f.ww:e.bb.d:k)
represents:

f.ww = firmware revision

e= the EBIOS version
bb.d= the Diagnostic version
k= keyboard controller version
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Server Mode
Table 2-5 lists and describes the Server Mode options.

Table 2-5 Server Mode Options

Server Mode Description

Init The controller firmware has been rebooted.

Held RSM prevents the server from booting.  This
allows diagnostics and configuration to be
done without an operating system running on
the server.

BIOS BIOS operating mode.  RSM intercepts and
emulates BIOS calls and recognizes a change
to the BIOS mode when the BIOS executes the
RSM controller EBIOS (after it is reset).

Run Run displays instead of BIOS if the RSM's
Extended BIOS (EBIOS) is disabled.

Reset The server has been reset.  This occurs when
the power comes on, you press the reset button,
and (depending on the server’s operating
system) when you press the server's
CTL+ALT+DELETE keys.

Power Off The server's power has been turned off.

NOTE: The Server Mode sequence during a normal boot is: RESET,
and then BIOS.  Some operating systems change from BIOS mode to
another Server Mode.  RSM cannot detect this mode change.  As a
result, the Status window displays Server Mode as BIOS, although the
server has actually exited from BIOS to an operating system running
state (RUN).
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Keyboard Status
Table 2-6 describes the Keyboard Status options.

Table 2-6 Keyboard Status

Keyboard Status Description

Normal The server’s keyboard cable is plugged
into the controller, the server’s power is
on, and the keyboard is operating
normally.

No System Response The server’s keyboard cable is plugged
into the controller, the server’s power is
on, but the keyboard is not responding to
RSM.

Controller Failure The RSM controller has failed.

Keyboard Cable
Unplugged

The keyboard cable is unplugged.

System Cable
Unplugged

The system cable is unplugged.

Remote Console A Remote Console window is open.
Keystroke input can be entered only from
the management station.

Power Off The server’s power is off.
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Updating Status
To update the log file view of the remote server status:

1. Select Update from the Server Log window.  The Update button
changes to Abort during the update.

2. Select Abort if you want to stop the update before it completes.

The message, "Log upload: the controller's log is empty" displays if there
are no new server log entries to transfer. This message displays only
once per session, even if you update the Status window several times and
each time there are no new server log entries for transfer.

Exporting and Printing Status
You can write server status to a file or print it using the Export and Print
commands in the File pull-down menu.  The Export command places
server status into a file.  The Print command prints status information
for the server.  The Export and Print dialog boxes have check boxes for
exporting or printing environment sensor values and/or log entries.  You
can also export or print a specific log entry or multiple log entries.

Printing Server Status
To obtain a printout of the status:

1. Select File from the menu bar.  Move the mouse pointer to File and
click once, or press ALT + F.  The File pull-down menu displays.

2. Select the Print command in the File pull-down menu. The Print
dialog box displays.

3. Set or clear the Print Sensor Data and Print Log Entries check boxes.

4. Select OK on the Print dialog box.
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Printing or Exporting Log Entries to a File
The status information includes the server name and description, if
applicable, followed by the requested information.  To select a complete
list, press CTRL + A.

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Export on the pull-down menu.  The Export dialog box
displays.
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 Figure 2-13 Export Setup

 

 

3. Set or clear the Export Sensor Data and Export Log Entries check
boxes.

4. Select OK on the Export dialog box.

5. Enter the file name in the File Name text box or choose a file name
on the File dialog box.  RSM prompts for a file name using the server
name.  The extension ".txt" is the default.

 Figure 2-14 File Dialog Box

 

6. Select OK on the File dialog box.

7. Select OK on the Confirmation dialog box.
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Advanced Functions3
This chapter explains how to manage your remote server from the
management station.  It details the following functions:

• Controlling server functions (power cycles, booting)

• Accessing a remote console directly from the management station
window

• Setting the clock times

• Transferring configuration files and memory to and from the remote
server and the management station

• Creating a direct hardwired connection

• Enabling the remote diskette to copy files
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Controlling Remote Server Functions
From the Control window on the management station you can control
the remote server functions, such as turning the server's power off and
on, booting, and transferring configuration files and memory.

1. Highlight the server you wish to connect to.

2. Choose Control from the Select Window.

Figure 3-1 Server Control Window

The title bar displays the connected server’s name and its connection
status. The Connection Status window lists various connection status
messages.
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Table 3-1 lists the buttons for Boot Operations and Other Operations.
The last row of the window contains buttons for Disconnect (or Connect
if the server is not connected), Open Console, and Close.

Table 3-1  Control Operations

Button Function

Power on Powers the remote server off or on.

Reset/Keys Resets the server or sends special key
commands to the  remote server.

Release Releases the server from Held mode and
sends special key combinations to the
server.

Set  Diskette Sets the Remote Diskettes feature.

Set Clock Sets the remote server and controller
clocks.

Transfers Transfer configuration and memory files.
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Powering the Remote Server On and Off
To turn the server's power on or off

1. Highlight the desired remote server in the Select, Server Directory
window.

2. Connect to the server.

3. Select Power Off or Power On button from the Control window.  The
Turn Power On or Turn Power Off confirmation box displays.

4. Select OK.

If you select Power On, you can also choose to place the server in HELD
mode after booting.  Held mode allows you to make additional changes
to the server, such as setting the server clock, and changing CMOS and
EISA configurations.  Held mode is further detailed later in this chapter.
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Resetting System Options on the Remote Server
RSM can remotely reset a server or send special keystroke combinations
to the remote server.   It is only able to complete this function if the
management station operates in unison with the remote server.  To align
these functions, set the reset/key information:

1. Highlight the desired server in the Select, Server Directory window.

2. Connect to the server.

3. Select Reset/Keys.  The Reset/Keys dialog box displays.

 Figure 3-2  Reset/Keys

 

4. Select a Reset option from the Reset/Keys dialog box.

5. Verify that the Hold on Boot box is blank.

6. Select OK .

Table 3-2 lists the Reset/Keys dialog box options.
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Table 3-2 Reset/Key Options

Option Function

Reset Equivalent to pressing the server's Reset button.

Cold Boot Enacts a reset via the motherboard keyboard controller.  This is not
supported on an XL server.

Warm Boot Equivalent to pressing CTRL+ALT+DELETE on the server’s
keyboard.  A server's response depends on the server’s operating
system.

Alt/Esc Equivalent to pressing ALT+ESCAPE on server keyboard that is
running Netware.

Set EBIOS Addr This is an emergency feature.  If the EBIOS does not operate (for
example BIOS address conflict), a temporary EBIOS address can be
set for the next warm boot.

Reset Firmware Reboots the controller’s firmware.  The Reset Firmware button
enables you to start a controller’s firmware remotely.  This is only
after manually transferring a new version of the firmware from
DIGITAL or to help diagnose a firmware problem.

NOTE: Resetting the firmware disconnects the management station
from the remote server. You must reconnect when the reset is complete.
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Putting the Remote Server in Held Mode
RSM can put a server’s operation on hold during power on and boot
operations.   This is called Held mode.

Held mode keeps the server's operating system from interfering during
server maintenance.  It is a requirement for the following tasks:

• Setting the server clock

• Transferring an EISA configuration

• Transferring CMOS setup

The Hold on Boot check box is located on the Power On and the
Reset/Keys dialog boxes.  A blank check box indicates that the option is
not active.  An X indicates that the option is active. Deactivate this
option if you want the operating system to boot up normally. To activate
held mode:

1. Highlight the desired server in the Select, Server Directory window.

2. Connect to the server.

3. Select Reset/Keys. The Reset/Keys dialog box displays.

4. Select one of the Server reset options from the Reset/Keys dialog box.

5. Verify that the Hold on Boot option is active by checking for an X in
the Hold on Boot check box.

6. Select OK.

Netware - Alt/Esc
To get similar results on a server running Netware, press the ALT and
ESC keys.  This command sends the Alt Escape combination to a remote
server.  This sequence is helpful for Novell servers.
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Releasing the Server from Held Mode
 Select Release from the Control window to remove the server from Held
mode and allow it to finish booting and resume normal operations.

NOTE: To change the server's mode when it is in Held mode you must
release or reset the server with the Hold on Boot box set to blank,  or to
physically reset the controller to its factory defaults (refer to the Remote
Server Manager Installation Guide). Resetting a server at the remote site
will not prevent it from going into Held mode.

Setting the Extended BIOS Address
This is an emergency feature that can be used if the RSM Extended
BIOS (EBIOS) does not operate.  This can occur if:

• The remote server’s NVRAM is corrupt

• The controller was installed without running the SCU

• The RSM EBIOS address conflicts with an ISA card

• No EBIOS address has been assigned

• The EBIOS download had been previously aborted and the server
has been reset (a warning displays when you attempt to reset a
server with a corrupt EBIOS).

To set the EBIOS address:

1. Highlight the desired server in the Select, Server Directory window,
and press Connect to connect to the server.

2. Select Set EBIOS Addr from the Reset/Keys window. The Extended
BIOS Address field displays.

3. Select the scroll arrow from the right side of the field.  A pull-down
menu with the associated EBIOS addresses displays.
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 Figure 3-3  EBOIS

 

4. Select an EBIOS address.  It displays in the EBIOS field.

5. Select OK.  A confirmation dialog box displays, verifying the new
EBIOS address setting.  Select OK.

6. Reset the server using a warm boot to make the address setting
effective.

7. Either run the SCU via remote diskette or download the saved
contents of the EISA configuration to make the setting permanent.
See the Remote Server Manager Installation Guide for further
details.

8. Reset again to complete the server configuration.
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Setting the Controller Clock or the Server Clock
The controller’s built in clock places a time-stamp on internal and
external remote server conditions.  It does this even when the server is
not operating.  If the remote server and the management station are in
different time zones, the controller adjusts the remote server’s time to
the management station’s local time.

The management station local time displays in the Management Station
Time window.  The remote server local time displays on the Remote
Server Times window.  You cannot directly reset the clock on the remote
server. Different procedures are used in setting the controller and clocks.

NOTE: The server must be in Held mode to set either the controller’s clock or
the remote server's clock.



Advanced Functions

57

Setting the Remote Server Clock
To set the remote server clock:

1. Highlight the remote server in the Select, Server Directory window.
Press the Connect button to connect to the server.

2. Select Reset from the Reset/Keys dialog box.  An X displays in the
Hold on Boot check box.

3. Select the Hold on Boot box on the Reset/Keys dialog box.  An X
displays.

4. Select Set Clock. The Set Clock(s) dialog box displays.

5. Select the Sys checkbox under the Set field.  An X displays.

6. Select Set Remote from the Local box.

7. Select Cancel to return to the Control Window.

Figure 3-4 Setting Clocks
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Setting the Controller Clock:
To set the controller clock:

1. Highlight the desired server in the Select, Server Directory window.

2. Connect to the server.

3. Select Set ClockThe Set Clock(s) dialog box displays.

4. Select the clock checkbox under the Set field to activate the setting.
An X displays.

5. Select Set Remote from Local.

6. Select Cancel to return to the Control Window.
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Using a Management Station as a Remote
Console

Use the Console window  to view a remote server console and enter
keyboard input remotely.  If the controller is attached directly to the
keyboard, it takes control of the server’s keyboard and prevents input
from the server’s keyboard.

The Remote Console feature works when the server is in text mode only.
It will work with Netware, SCO, and other text mode interfaces.  It does
not support Windows and other graphical interfaces.

RSM sends management station keystrokes to the remote server when
the Console window is the active window.  RSM sends all keystrokes
from an active Console window to the server’s input or console port for
processing by the server.
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Figure 3-5 Console Interface
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Entering Keyboard Input Remotely
To use the management station as a remote console, the server must
have a VGA frame buffer that is readable from the EISA bus.

1. Highlight the desired server in the Select, Server Directory window.

2. Connect to the remote server.

3. Select Open Console on the Control window. The Console Window
displays.

4. Monitor the server console and enter keyboard input remotely as
required.

5. Select Control from the menu bar.  The Control pull down menu
displays.

6. Select Close from the Control pull down menu.

The VGA remote console works when the server is in TEXT MODE
ONLYgraphic modes are not supported.  If the server is configured
with a PCI-based on-board VGA video controller, an ISA video
controller  (part number FR-PCXAG-BC) is required for the remote
console.

NOTE: The console window does not display when the server is in
graphics mode, for example, when NT is running.  You can still see some
information by opening a full screen MS-DOS window.  You can remotely
control the server through commands typed in the MS-DOS window using
a remote keyboard.
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Please consider the following when using the remote console tool:

• The Console window displays as an empty black screen when the
remote server is powered off.  If a connection to a server fails, RSM
continues to display what was on server’s screen.

• The colors on the server may not be the same as the colors in the
Console window, because the application uses a non-standard color
map.

• Menu commands do not have keyboard equivalents in the Console
window, since RSM sends all keyboard input directly to the server.

• The bell character causes a beep at the remote server, which is
neither visible nor audible at the management station.

• Opening the Console window makes the remote server keyboard
nonfunctional.  The remote server keyboard LEDs reflect the
management station keyboard settings.
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Creating a Direct Connection to the Remote
Server

The management station can be connected directly to the remote server
using an RS232 serial line cable connecting the RSM controller on the
remote server to the management station’s communication port.  This
connection requires a null modem cable.   See the Remote Server
Manager Installation Guide for directions on creating this cable.

Configure the serial port in Microsoft-Windows NT 3.51 Control Panel –
Ports .

1. Edit the  \RS_MGR\rs_pm.ini  port communications file.

2. Identify the port initialization string to direct connect with a server
name.

 rs_pm.ini

 [PORTS]

 com1=:d:server2

 com1   =  :d            :  server2

 This example identifies: Comm port 1, No Modem, Direct: server
name=server2

3. Start the RSM port manager and RSM software.

4. Select any server name and choose Setup.  The Setup screen for the
new server displays.

5. Choose New from the Setup screen.

6. Setup the server as “server2”.  Open <new action> in the Connection
Actions window and select No Connection.  The default files have
existing entries for the direct connection.
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 Figure 3-6 Server Setup

 

7. Purchase or construct a null modem cable.  See the Remote Server
Manager Installation Guide for details.

8. Open the Control Panel and select Ports Setup.  The following screen
displays:



Advanced Functions

65

 Figure 3-7  Comm Port Setup

 

9. Set the following values in the Settings window:

Baud rate 38,400  (This is the speed at which the communication
port on  the RSM  controller communicates)

Data Bits 8

Parity None

Stop Bits 1

Flow Hardware

10. Select Advanced.  The following screen displays:
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 Figure 3-8 Advanced Comm Port Settings

 

11. Set the I/O Port and IRQ in the Advanced Settings window to the
default value or to another value.

12. Select FIFO Enabled.

NOTE: The controller requires a Carrier Detect signal in the RS232
cable.  See the RSM Installation Guide for details on cable
requirements.
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Communicating with the Remote Server Through
Remote Diskette

RSM allows you to boot a remote server using a diskette or a diskette
image file on your management station through the Remote Diskettes
feature. You can also use this feature to transfer data or run diagnostics.

NOTE: The server must be in BIOS mode to use the Remote Diskettes
feature.  Although you can start a remote diskette at any time, it
operates only when the server is in BIOS mode.

NOTE: Some operating systems and utilities can change the Server
mode.  RSM cannot detect this change.  If a change occurs, BIOS
displays as the value in the Server Mode field on the Server System
Status.  Therefore, you need to know which Server Mode is currently in
use by the server software. DOS always uses the BIOS mode.

1. Verify that the remote server is in BIOS mode.  Remote diskette
should also work in Reset mode.

2. Select Set Diskette on the Control window.  The Diskette Setup
dialog box displays.

NOTE:  If you experience problems, you may have to reset the remote
system to clear the Server Mode.
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Figure 3- 9  Diskette Setup

3. Select the drive on the remote server that you would like the remote
server to simulate: (A: or B:).

4. Select the Mode field.  Normal is the default. Change the field value
by selecting the scroll arrow and displaying a different mode.

Table 3-3 lists the Remote Diskettes Modes.

Table 3-3 Remote Diskette Modes

Mode Function

Disabled Disables the diskette drive on the server.

Normal (at Server) The server's diskette drive is the local drive.

Read only (at Server) Disables writing to the server's diskette drive.

At Management Station Uses the management station's diskette drive or an image
file as a remote drive for the server.

At Management Station
Read only

Uses the management station's diskette drive or an image
file on the management station for read only. Multiple
servers can share the read-only image file on either drive
A or B.
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Remember to consider the following when using the remote diskette
feature:

• Dependent on the mode, you can manipulate a file, or work with a
read-only file from either the remote server or the management
station.

• In At Management Station or Management Station Read Only
modes, enter the file name with the correct path and drive, such as
drive A: or B:, If you are using a diskette image file you can also use
the Browse button to find an image from a directory on your
management station.  In all other modes, enter the file name to be
used.

• Select Set Diskette Configuration causes RSM to update the current
settings in the Server Diskette Drives window on the Control
window.

• The server remembers whether a previous setting was Disabled or
Normal and reverts to that setting if the server is disconnected while
in At Management Station to At Management Station Read only
mode.

• You may want to reset the CMOS setup to prevent it from booting
from drive A when setting the diskette mode to Disabled.  The
Disabled and Read only modes remain even when the server or
controller loses power.

• Do not use the Remote Diskette feature with the DOS SMARTDRV
program without using the "a-" or "b-" options on the SMARTDRV
line.  Failure to use these options leads to very long diskette
response times.
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Security 4
Creating Security Files

RSM uses traditional NT security systems with user ID’s and passwords
combined with specific RSM conventions.  The security user information
is stored in security files and memory locations that contain user names,
groups, and passwords. Up to 100 users can be defined using the
Security Definitions window.

Two basic security options in the RSM application are assigned: No
security and User security, and a third dialback strategy to ensure
secure access.

The No security option allows full access to the remote servers from the
management station. DIGITAL recommends that you implement user
security once you feel comfortable using RSM to manage servers.

With the User security option, users are defined and a security file is
created which is sent to the remote server.   A user is defined as being a
member of a group, each of which has different privileges. The groups
are User, Super User, and Administrator. These groups are placed into a
security file which is transferred to the server in encrypted form.
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Another security feature is Dial-back in which an RSM script rings the
management station and hangs up.  The management station then
automatically dials the remote server. This would ensure that remote
server access is available to only one authorized management stations.

NOTE: The controller is shipped from the factory with the security features
disabled. Normally the security features on the controller are set from the
remote server management station. The security modes and passwords are
saved in the non-volatile memory on the controller.   To reconfigure the
controller, refer to the Remote Server Manager Installation Guide.

Users are divided into one of three groups:

User Has access to a server, view server status, use a
management station as a remote console, and
transfer Events, Macros, Scripts, Firmware, and
Extended BIOS files from a server to the
management station.

Super User Has access to all the RSM functions except
resetting the firmware and transferring security,
firmware, and extended BIOS files from the
management station to a server.

Administrator Has access to all RSM functionality.
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Creating a New Security File
To create a new security file:

1. Select Options from the menu bar.  The Options pull-down menu
displays.

2. Select Security from the Options pull-down menu.  The Security
submenu displays.

3. Select New from the submenu.

Editing a Security File
To edit the security file:

1. Select Options from the menu bar.  The Options pull-down menu
displays.

2. Select Security from the Options pull-down menu.  The Security
submenu displays.

3. Select Open from the submenu.

4. Select a security file name from the File Name pane on the Open
dialog box, or enter a security file name in the File Name text box.

5. Select OK from the Open dialog box.

NOTE: Transferring a blank security file to a server eliminates RSM
security.  RSM displays a warning message if you attempt to save a
security file with no user information.  Confirm to save.

NOTE: Verify that the security file that you transfer to a server has at
least one user with Administrator privileges.

The Script Definitions window displays after you complete any of the
above procedures.  The window title bar displays the name of the file
being edited, or <unnamed_n> until you save a new file.  The window
appears blank for a new file, and displays the user names, groups, and
user passwords when you edit a specified file.



Security

74

Figure 4-1 Security Definitions

Saving Security Files
To save a security file:

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Save or Save As from the pull-down menu.  The Save dialog
box displays.

3. Enter the file name in the File Name text box, or select a security file
name.

4. Select OK from the Save dialog box.

Assigning Security for Specific Users
Assigning user names to each person requiring access to the
management station or the remote server.
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Adding a New User
To add a new user:

1. Select <new user> from the User Name field on the Security
Definitions window.

2. Enter a user name.  The user name can contain up to 20 characters.
RSM displays User as the default group.  If the user is in the User
Group, continue to step 3.  Otherwise, select User to display the
group options.

3. Enter the user’s password (if you use RSM passwords). The password
can contain up to 12 characters.  A Confirm Password dialog box
displays.  Re-enter the password.

Figure 4-2 Defining Security Group
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Inserting, Deleting, and Reordering User Names
User names can be inserted, deleted, and reordered with the Delete,
Insert, and arrowhead buttons at the bottom of the User Name pane of
the Security Definitions window.  The Insert button inserts a new user
name before the currently selected User Name.  The Delete button
deletes the selected user name.  The arrow buttons in the bottom right
corner of the window enable you to reorder the user names.

Inserting a User Name into an Existing User Name List
To insert a user:

1. Select the line before the one where the user name is to appear.

2. Select the Insert button.  If a user name already resides on that line, it
moves down one line.

3. Enter the user name.

Deleting a User Name
To delete a user:

1. Select a user name.

2. Select Delete.



Security

77

Reordering a User Name
To move a user name:

1. Select a user name.

2. Select either the up arrow button or the down arrow button.  The up
arrow moves one line up each time you select it.  The down arrow
moves one line down.

3. Select the up or down arrow button and reinsert the user name on the
list.

NOTE: If you forget your Administrator password, you will need to reset
the controller toits default file, factory defaults (no security) before you
can perform any function that requires Administrator privileges.

NOTE: You must have physical access to the remote server to power
cycle the controller with an attached jumper. Refer to the Remote Server
Manager Installation Guide for more information.
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Dialback Security Feature
The dialback security feature allows the server, upon connection from
the Management Console, to hang up and dial back to the Management
Console's modem.  The server does this by reviewing a macro file
downloaded to the RSM controller.  If a "dialback" macro already exists,
the feature is enabled.

The dialback feature is set up by first identifying that the RS_PM.INI file
has the [a] option in the command line for the COM port.  To do this:

1. Open the RS_PM.ini file.

2. Check for the following, and edit if necessary.

 [Ports]
com1=zoom:oa

       where:

  o= Originate
  a= Answer
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Setting Up the Dialback Feature
To add dialback to your system:

1. Open the Macro file by selecting  Options menu, and then choose
Macro.

2. Select Open and choose the SRVM.MCR file.

3. Create a new macro labeled dialback (use lower case).

 Figure 4-3 Creating Dialback Macro

 

4. Highlight the ms1 macro name and add the remote server’s
telephone number.
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 Figure 4-4 Edit MS1 for Dialback

 

1. Highlight the dialback macro name.

2. Click on the <new action> label and choose Include.  Click on the
<new value> and enter ms1.

3. Click on <new action> and choose Dialback.  Do not assign a new
value.

4. Select SAVE from the File menu.
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Figure 4-5 Edit Dialback Macro

WARNING: If possible, test the dial-back to a localized remote server.  If the
dialback setup does not work properly you may create a loop in the
telephone dialing service to the remote server.  If this happens you will need
to reset the controller manually as detailed in the Remote Server Manager
Installation Guide.  Resetting this way must be done at the remote server site.

1. Highlight the remote server from the Select window you want to be
dialed back from the Management Station.

2. Connect to the Server.

3. Select Functions from the Toolbar.

4. Select Transfers To/From.  The screen displays the files currently
downloaded on the server.

5. Highlight the SVRM.MCR file, and press Transfer.

6. Disconnect the remote server.

7. Reconnect to the server and test the dialback feature.  Figure 4-6
displays the positive results.
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Figure 4-6  Dialback Status
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Management System Menus and Options 5
This chapter describes the RSM management station menu and options
windows for the application.

Remote Server Manager Menus
The RSM menu bar contains six commands: File, Edit, Functions,
Options, Window, and Help.  The menu commands follow industry-
standard Windows conventions.  A default window, Select, opens when
RSM is started.
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Control Window
RSM uses the standard Windows control menu, located in the upper left
corner.  Table 5-1 lists the control window commands.

The Control menu can be started manually by completing the following:

1. Select the Control menu box located in the upper left corner
(indicated by a hyphen).

2. Move the mouse pointer to the Control menu icon and click, or press
ALT+SPACEBAR.  The Control menu pull-down menu displays.

3. Select a command.  Press ALT if you want to close the menu without
choosing a command.

Table 5-1 Control Window Commands

Command Description

Restore Restores the window to its former size after it has
been enlarged (using the Maximize command) or
shrunk to an icon (using the Minimize
command).

Move Allows you to use the keyboard to move the
window to another position on the desktop.

Size Allows you to use the keyboard to change the
size of the window.

Minimize Shrinks the window to an icon.

Maximize Enlarges the window to its maximum size.

Close Closes a window and removes it from the list of
active windows on the Window menu.

Task (Switch To) Starts Task List.  This lets you switch among
running applications.
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File Menu
The File menu has four possible logical groups.  These groups are
specific to the connection in the active window, so not all groups are
present for all windows.

Table 5-2 describes the File menu commands.

Table 5-2 File Menu Commands

File Command Description

Save As Saves file to a specified file name.  Saves the
contents of a Console window into a specified file.

Export Adds server status into a file.

Print Prints server status.

Print Setup Provides standard printer setup information, such
as printer name, type of form, page orientation,
number of sides to be printed, document
properties, and network connections.

Exit Exits RSM.  If the Save Window Layout option is
on, RSM saves the window arrangement.  If not
set, RSM will ask if you want to save this
information before exiting.
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Functions Menu
The Function menu (Figure 5-1) does not show all the commands that
might display.  The function menu commands are specific to the
connection in an active window and are not available in all windows.
The Functions menu displays from the Control window.

Figure 5-1  Functions Menu
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Table 5-3 lists all the possible Functions commands.

Table 5-3 Functions Menu

Command Description

Connect/Disconnect Connects to a server.  Disconnect displays after a successful
connection is made to a remote server.

Edit Setup Displays a Setup window for the active server.

Open Console Displays a Console window for the active server.

Show Control Displays the Control window for the server in the active
window.

Transfer to/from Displays a Transfers window for the active server.

Update Status Updates the status of the active server.

View Status Displays a Status window for the active server.

Power Off/Power On Displays the Power On/Power Off dialog box.

Reset/Keys Resets the server or sends the server special key commands.
Displays the Reset/Keys dialog box.

Release Releases server from Held mode.

Remove Removes a selected server(s). A confirmation box displays to
confirm each server deletion.  You can suppress individual
delete confirmations by selecting YES-TO-ALL in the
Confirmation dialog box.

Setup New Opens a Setup window with all fields blank.  This command is
an alternative to the New button on the Setup window.

Set Clock Displays the Set Clock dialogue box.

VGA Console Displays the active server's VGA Console window.

Set Diskette Displays the remote diskette settings.
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Options Menu
The Options menu lets you determine what you want reviewed on the
remote server.

Figure 5-2 Options Menu

Table 5-4 lists the Options menu commands for a VGA console connection.
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Table 5-4 Options Menu Commands

Command Description

Preferences Displays the Preferences dialog box.

Events Displays a submenu consisting of:
New -    Displays the Events Definitions dialog box.
Open-    Displays the Open event definitions file dialog box.

Highlight a file. Select OK.
Delete-  Displays the Delete event definitions file dialog box.

Highlight a file. Select OK.
Macros Displays a submenu consisting of:

New -    Displays the Macros Definitions dialog box.
Open-    Displays the Open macro definitions file dialog box.

Highlight a file. Select OK.
Delete-  Displays the Delete macro definitions file dialog box.

Highlight a file. Select OK.
Scripts Displays a submenu consisting of:

New -    Displays the Scripts Definitions dialog box.
Open-    Displays the Open Scripts Definitions File dialog box.

Highlight a file. Select OK.
Delete-  Displays the Delete Script Definitions File dialog box.

Highlight a file. Select OK.
Security Displays a submenu consisting of:

New -    Displays the Security Definitions dialog box.
Open-    Displays the Open Security Definitions File dialog box.

Highlight a file. Select OK.
Delete-  Displays the Delete security definitions file dialog box.

Highlight a file. Select OK.
Sort by Name Displays servers in alphabetical order by name.

Sort by Last Contact Displays servers in order based on the time of last connection.

Sort by Connect
Time

Displays servers in order based on elapsed time of connection.

Sort by Alert
Pending

Displays servers with pending event alerts.

Ascending Sorts in ascending alphanumeric order (A-Z, 0-9).

Descending Sorts in descending alphanumeric order (Z-A, 9-0).
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Windows Menu
The Windows menu commands are specific to the current connection
and are not available for all connections.

Figure 5-3 RSM Windows Menu Options

Table 5-5 details the Windows menu commands.
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Table 5-5 Windows Menu

Command Description

Cascade Displays windows by offsetting a window lower and
to the right of a previously visible window.

Tile Displays windows in screen quadrants.

Tile Server Arranges the remote server's open Control, Status,
Setup, and Console window in screen quadrants. If
the active window is a Select window, the server
selected is the one that tiles.  If there are multiple
selected servers in the active window, the first
selected server tiles.

Close Server Closes all open windows for the selected server.

Close All Closes all open windows.

Get Select Displays a submenu with New and Select.  New
displays a blank Select window.  Select displays a
previously created Select window.

Get Options Makes an existing Options window the active
window.

Server
Window List

Switches to a new or different window for a
particular server.  A submenu listing Tile, Close,
and access to the RSM configuration windows
displays.

Help Menu
Table 5-6 lists and explains the Help menu commands.

Table 5-6 Help Menu Commands

Command Description

Contents An alphabetic list of all Help topics.

Search for Help Locate information about a specific topic.

How to Use Help Information on using Windows Help.

About … RSM version, company, and copyright version.



Management System Menus and Options

92

Main RSM Windows
RSM uses the following six windows to perform specific remote server
management functions:

Table 5-7  RSM Control Windows

Window Function

Select Enables you to select specific servers.  You can
open multiple Select windows, each containing a
subset of servers, by using filter options.

Setup Enables you to define a server, the connection
parameters, and default file names for the
transfer.

Status Enables you to view the Server Event Log and
status.

Control Enables you to access, monitor, maintain, and
control a server.

Transfers Enables you to transfer server files and memory
between the server and the management station.
Server files refer to the files needed to access and
control the remote monitoring of the server, as
well as to the server's configuration.

Console Enables you to monitor VGA console and to enter
data from the management station keyboard.
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Supporting Windows
RSM also uses the following windows and dialog boxes to support main
windows:

Table 5-8 RSM Definition Windows

Window or Dialog Box Supporting Task

Preferences Allows you to customize global
application settings.

Event Definitions Allows you to select a variety of server
conditions and define RSM's response to
those conditions.

Macro Definitions Allows you to define macros that consist
of a series of actions to be executed when
an event occurs.  Macro definitions are
also used to define event actions or
connection actions.

Script Definitions Modem scripts that Expect/Send
definitions to make a connection.  A
CHAT script is sent to the modem.  This
is a series of Expect and Send dialogs to
connect the management station to its
modem. You can use a CHAT script to
connect your management station to a
server.  The controller uses a CHAT script
for dial-back and to connect to a
management station when an event alert is
sent.

Security Definitions Enables users to specify user names, user
groups, and passwords.
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Viewing Servers in the Select Window
The Select window shown in the following illustration displays basic
information about each server.  Initially, the only server listed in the
Select window is the default server “server_1”.  Once a new server is
defined and saved, it appears in the Select window.

Current keyboard focus is visible as a dotted rectangle.  Current
selections are visible with color highlighting.  Use the scroll bar or the
arrow keys to view all the managed servers. Use the display and filter
options to create multiple Select windows with a subset of servers.

Figure 5-4  Filtering
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Directory Window
The Server Directory window displays a summary of information about
each server.

Figure 5-5  Server Directory Window
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Table 5-9 describes the fields in the Server Directory window.

Table 5-9 Server Directory Commands

Field Description

Server The server's unique name, also called the Short
Name.

Alert The elapsed time that an event alert has been
waiting, in either hours and minutes or number of
days.  Field is blank if no alert is waiting.

Session The elapsed time of the current connection in
either hours and minutes or number of days.  If
there is no connection, this field is blank. If a
connection is in process, the field displays
“Pending.”

Last Contact   If connected, the time and date of the most recent
connection.

If not connected and the RSM sent an event alert
during the last connection, the time and date RSM
sent the alert.

If not connected, displays the time and date the
connection was closed.

Description The server’s long, descriptive name and
information field.
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Display Options
You can display all the servers you are managing or you can view them
in a preferred Sort order on the Select window.  You can also limit the
number of servers that display by filtering them together by a user
required term. These filters, called attributes, let you devise your own
attribute names, and create filters specific to your sorting needs.  The
Sort options are available on the Select window Options menu; the
attribute option is in the Select window below the server directory

Sorting Options
You can sort servers in ascending or descending alphabetical order by
name, last connect time, connect time and alert pending.  The default is
to sort by name.  The current option has a check mark before the option.

1. Choose Options from the RSM windows.  The Options pull-down
menu displays.

2. Select the specific Sort by command from the Options pull-down
menu that meets your needs.

Attribute Options
The Filter option lets you sort servers by  specific attributes.  The servers
will display in the Select window below the Server directory.

Before sorting, complete the following:

1. Enter the Server Attribute Names in the Preferences window.

2. Enter the Server Attribute Values in the Setup window that
corresponds to each remote server.
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Sorting Servers with Specific Attributes
To sort for a specific attribute:

1. Select <new filter> in the Filters window.

2. Select a Server Attribute Name.

3. Select Test on the Filters menu bar.  The Test pull-down menu
displays.

NOTE: Based on the specific options for an event, not all of these
symbols will display.  Only those symbols that are applicable to the
event will display.

Ranges can be given for alphanumeric or numeric values.

Test Description

== Equal

!= Not equal

[ ] Inside a range [1,3]

] [ Outside a range ] 1,5 [

> Greater than (2 > 1)

< Less than (1 < 2)

4. If you are doing any other tests, choose Equality.  Select the scroll on
the right side of the field and select one of the other test alternatives.

5. Select <none> in the Value field and enter a Server Attribute Value.

6. Select Keep/Drop from the Filters menu bar. The Keep/Drop pull-
down menu displays with the default (Keep).

7. To remove a server, select the scroll arrow on the right side of the
Keep/Drop field.  The Keep/Drop pull-down menu displays.  Select
Drop.

8. Select the X displayed in the Enable field.  The X toggles to a check
mark.  The check mark activates the filter criteria and includes the
criteria in the filter operation.
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Modifying Server Attribute Criteria
To change attributes you have assigned to the servers:

1. Select the attribute name where you want to insert the additional
criterion.

2. Select Insert.  The selected attribute name moves down one line,
leaving a blank line.

3. Enter the additional server attribute criterion on the blank line.

Deleting a Server Attribute
To delete an attribute assigned to a server:

1. Select a server attribute criterion name from the list.

2. Select Delete.

Reordering Server Attributes
To reorder the list of server attributes:

1. Select a server attribute criterion name from the list.

2. Select either the up arrow button or the down arrow button.  The
selected criterion will move one line up each time you select the up
arrow button.  It moves one line down each time you select the down
arrow button.

3. Move the server attribute to a new location on the list.
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Switching to a Different Window
You can open a new RSM window using Window.  The Window pull-
down menu lists the names of all servers with currently open windows.

Moving Between Server Windows
To change to a different server window:

1. Select a server name from the Window menu.

2. Select Window from RSM menu bar.  The Window pull-down menu
displays.

3. Select the RSM window you want to make active and visible.

Displaying All Active Server Windows
To view all the active servers:

1. Select a server window.

2. Select Window from the menu bar.  The Window pull-down menu
displays.

3. Select Tile Server from the Window pull-down menu.  The active
server windows display.

Closing all Active Server Windows
To close all the active server windows:

1. Select a server window.

2. Select Window from the menu bar.  The Window pull-down menu
displays.

3. Select Close Server from the Window pull-down menu.  All server
windows will close.  Close Server will not disconnect an established
server connection, unless "Disconnect on Control Close" preference
option is in use.
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Removing a Server
If required, you can remove a server from the list of supported servers in
the Select window.  Removing the server closes any active windows for
that server and deletes all associated files.

1. Select Functions from the menu bar.  The Functions pull-down menu
displays.

2. Select "Select Servers".  The Select window displays.

3. Select a server or multiple servers from the Server Directory.

4. Select Functions from the RSM menu bar.  The Functions pull-down
menu displays.

5. Select Remove.  A Notification confirmation box displays.

6. Select Yes to delete the server information.

Disconnecting from a Server
You can disconnect a server using the Functions pull-down menu or the
Disconnect button on the Control window.

1. Select Functions from the menu bar.  The Functions pull-down menu
displays.

2. Select Disconnect from the Functions pull-down menu or select
Disconnect on the Control window.
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Global Accelerator Commands
Global accelerator keys enable you to type at the management keyboard
that will take place on the remote server.   The commands apply to all
active remote servers.  If a command operation does not apply, a beep
sounds.  These commands are used while in the Console window on the
management station.

Table 5-10 Global Accelerator Commands

Accelerator Keys
(CTRL+ ALT+)

Definition

Escape Aborts any server operation in progress

C Select the active server's Control window

E Select the active server's Setup window

H Help (same as selecting Contents from on-line
Help)

N Open a window to Setup a new server

Q Quit Remote Server Manager

O Open the default console (SHIFT+O to open
the other console)

S Select the active server's Status window

T Select the active server's Transfer window

V Select the active server's VGA console window

W Tile the active server's windows ( SHIFT+W to
close the tiled windows)

Page Up Tile the previous active server ( SHIFT+PAGE
UP to close current server window)

Page Down Tile the next server (SHIFT+PAGE DOWN to
close the server's windows)

F1 Console windows (F1 to send through to the
remote host)

1, 2, 3, 4 Tile 1, 2, 3, or 4 windows
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Table 5-11 Accelerator Keys

Accelerator
Keys (CTRL+)

Definition

A Select All.  This is specific to an active server
(all servers in the Select window, and all log
entries in the Status window)

B Clear a selected editable field

C Copy selected command(s) to the Clipboard

P Print server information

S Save a file

V Paste text from the Clipboard to an editable file

X Cut the selected text

Preferences File
The preferences file contains global application settings.  This file
provides continuity by allowing you to keep the same user preferences
and window arrangements from the previous session each time you start
RSM.  RSM uses the default settings if it cannot find this file at startup.
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Modifying Configuration Files6
This chapter describes how to edit server configuration files, including
events, macros, scripts, and security files.

These configuration files are the same ones used during the installation
process as detailed in the Remote Server Manager Installation Guide.
This chapter details the further use of these configuration files and
explains how to edit them to provide the information and connectivity
about and to your specific remote servers.  RSM:

• Uses a windows driven interface to edit the text files. The text files
can also be edited directly in text format with a line editor.

• Provides default files for the events, macros, and scripts files.  The
file names are srvm or examplex (x signifies a number, starting with
1) plus the appropriate extension (.evt, .mcr or .scr).  Refer to
Appendix B, Sample Configuration Files for more information.
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 This chapter describes the following kinds of configurations that can be
changed in RSM:

 Events  Defines the server conditions RSM should monitor and the actions it
should take when these conditions exceed specified limits.  Refer to the
events file srvm.evt.

 Macros  Defines macros.  Macros can define single or multiple actions that
occur in an event or a connection action.  Refer to the file srvm.mcr for
an example of a macros file.

 Scripts  Defines communication dialogs used to make a connection between a
management station and a server or to send an event alert to a pager.  A
script is a sequence of alternating “expected input” and “next output to
send” pairs that define a dialog via a serial port.  Refer to the file
srvm.scr for an example of a scripts file.

 Security  Defines user names, their groups, and passwords.  Refer to the file
srvm.sec for an example of a security file.

 Server  Defines server names and attributes, connection actions, and default file
names for transfer.  The server file extension is .sdf.

 Server Log  Defines time stamped log files for each server.  The server log file
extension is .log.

 Preferences  Defines global application settings, including window arrangements
and user preferences, that provide continuity across multiple RSM
sessions.  The preferences file extension is .prf.

 

 The RSM file names default from the server Setup screen. You can
modify the default files or enter your own user-defined files and file
names.

 The maximum size of a server configuration file is 2K.  If you attempt to
transfer a bigger configuration file the transfer may fail and an error
message displays.
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Table 6-1 describes the default server files and memory options.

 Table 6-1 Default Files

Server File or
Memory

File Name Description

 Scripts  srvm.scr  Defines the communication dialog used to make a
connection between a remote server and a
management station, or to send an event alert to a
pager.

 Action Macros  srvm.mcr  Defines macros that define event and
communication actions.

 Events  srvm.evt  Defines events and RSM's actions that take place
when each event is triggered.

 Security  srvm.sec  There is no Security File. Security is optional.
You must customize it with Users, Passwords, and
Permission Levels.

 Keystroke Log  server.klg  Contains the specific characters typed on the
keyboard since the last reset.  This file holds up to
128 characters and discards any additional
keystrokes beginning with the oldest character.
You can transfer the Keystroke Log file to a
management station only.

 CMOS Setup  Server.cms  Specifies the binary contents of CMOS memory.
When you transfer CMOS memory to your
management station, RSM copies the entire
contents of CMOS setup memory.  When you
transfer this file to a server, RSM copies
everything in CMOS setup memory except the
time. (Time contains zeros.)

CONTINUED
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Server File or
Memory

File Name Description

 EISA Configuration  Server.ecu  Specifies the binary contents of EISA
configuration memory.

 Firmware  fw_main.abs  Contains the firmware for the controller.

 Extended BIOS  ebios.rom  Contains the BIOS extension program for the
controller.
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 Events Files
 An events file lists the server conditions and the actions taken when
these conditions exceed user specified limits.  The controller regularly
checks the status of the remote server and compares the current values
against those listed in the server's events file.  If an event has occurred,
the controller performs the actions that corresponds to that event as
listed in the server's events file.

 The events file, srvm.evt, and Appendix B give examples of some typical
server conditions RSM monitors and automatic actions that it performs.

 Overview
 RSM defines an event as:

 <state> <sensor parameter> <test> <limit> <action1>, <action2>...

 The statement means: when the server is in a specific state <state>, and
the <sensor parameter> does a comparison test <test> and the value
<limit> is true, perform the actions in the order as they occur <action1>,
<action2>.  An event occurs only when the comparison goes from false
to true.  If an event  remains true the next time, a new event will not
occur and RSM checks the sensors.

 The Event Definitions window enables you to:

• Define the server conditions that the controller monitors

• Define the actions to take when a server condition exceeds a
specified limit

You can create new events files and change existing files.  RSM provides
an example events file (srvm.evt). You can customize this file or create
your own.
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Creating a New Events File
Create a new events file to create a completely new sequence of events
performed on the remote server.  To create a new events file:

1. Select Options from the menu bar.  Move the mouse pointer to
Options and click, or press ALT +O.  The Options pull-down menu
displays.

2. Select Events from the Options pull-down menu.  The Events
submenu displays.

3. Select New from the Events submenu.

Editing an Existing Events File
To edit an existing events file:

1. Select Options from the menu bar.  The Options pull-down menu
displays.

2. Select Events from the Options pull-down menu.  The Events
submenu displays.

3. Select Open on the submenu.

4. Enter the file name in the File Name text box, or choose the file
name of the Events file on the Open dialog box.

5. Select OK on the Open dialog box.

The Event Definitions window displays after you complete any of the
above procedures.  The window title bar displays the name of the file
being edited, or <unnamed_n> until you save a New file.  The Event
Definitions window displays blank for a New file, and displays the
applicable information for previously created events.
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Modifying Event Actions
Use the Actions Associated with Selected Event window to define the
actions RSM must take when an associated event occurs.  You can define
single or multiple event actions for each sensor parameter.  

Defining Sensor Parameters
Sensor parameters are defined as when a server's +3.3V power sensor
parameter is outside the +3.0V to 3.6V range  To modify this parameter:

1. Open an existing events file or a newly created events file (i.e.
srvm.evt) from the Options window.

2. Select <new event> from the Parameter menu.  The Parameter option
box displays.

3. Select the scroll arrow to display the available parameter options.
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 Figure 6-1 Event Definitions Menu

 

4. Select +3.3V power.  The default parameters for the connection in
the active window display.
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 Figure 6-2 Event Definitions Window

 

 The default test symbol is ][ (outside the range).

5. Select the default test symbol. The Test options display with a scroll
arrow.

6. Select the scroll arrow to view the other test symbols and select the
applicable symbol.  You can define up to 100 events.

NOTE: If you enter a number with either a - or + sign, the sign must
precede the value with no leading spaces.  Use a comma to separate
any values that you are testing that are inside or outside a range..
The values always display in ascending numerical order even if you
enter them in descending numerical order.
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Table 6-2 lists all of the sensor parameters and their default values:

Table 6-2 Sensor Parameters

Parameter Default

+3.3V power Outside  +3.0V to +3.6V range.

+5V power Outside  +4.5V to +5.5V range.

+12V power Outside  +11.0V to +13.0V range.

-5V power Outside  -4.5V to -5.5V range.

-12V power Outside -11.0V to -13.0V range.

Temperature* Greater than 27ºC (80ºF).

Temp Deg/hr* Greater than 1ºC (1ºF).

Ext Pwr (V) Outside 4.5 to 5.5 range.

Keystrokes Greater than 0.

Server mode Equal to INIT.
*  RSM converts Temperature from Celsius to Fahrenheit on the
Preferences window Options pane.

Event Tests
The Test field displays the test symbol associated with the parameter you
selected.  Only test symbols available for the connection in the active
window are displayed.
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Figure 6-3 Event Test Symbols

The following table lists the event test symbols.

Test Description

== Equal

!= Not equal

[ ] Inside

] [ Outside

> Greater than

< Less than
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Powering Off Server When Temperature Exceeds Set Threshold
To ensure that the server powers down when the environmental
temperature exceeds acceptable thresholds:

1. Choose <new action> from the Actions Associated with Selected
Event pane. The <new action> pull-down menu displays.

2. Select the arrow located on the right of the <new action> pull-down
menu.  The <new action> options display.
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 Figure 6-4  Event Actions

 

3. Select Power from the pull-down menu.  The pull-down menu closes
and Power displays with its defaults.  The default value for Power is
On and displays in the <new value> field.

4. Select On.  A scroll arrow displays on the right side of the <new
value> field.

5. Select the arrow.  On and Off display.  Select Off.

Table 6-3 summarizes the event definitions.
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Table 6-3 Event Definitions

Action Description

Boot=type Boot or reset.  Type can be reset, cold, or warm.

Hangup Hang up the serial port.

Include=command Perform additional actions, as specified in the line starting with the
command command in the Macros file.

Log with Tag=log Make a log entry with Tag 0-255.

Pause=pause Wait X seconds before proceeding to the next action (Pause=00-99).

Power=on-off Set power.  On-off can be on or off.

Retry=n Repeat the actions n times if a connection fails. n=0-99 - 2-digit
field.

Script=script Execute the script with the name script.

Send Alert Send an alert.  If the telephone line is unavailable, an event alert is
not sent.

Speed=baud Set the baud rate of the serial port to baud  300, 1200, 2400, 4800,
9600, 14400, 19200, 38400, or 57600 (default=2400).

State=state Enter State. A State variable is useful when you want RSM to
conditionally perform an action.  For example, when you want to
send alter when server power is Off. State=0-255 - 3-digit field.

Stop on
Failure?=yes or no

Stop or continue subsequent actions if an action fails. Yes= stop if an
action fails.  No= continue with subsequent actions if an action fails
(default = Yes).

Stop on
Success?=yes or no

Stop or continue subsequent actions after a successful action.. Yes=
stop if an action succeeds.  No= continue with subsequent actions if
an actions succeeds (default = No).

Telephone=number Set the telephone number.  Number = number to be dialed, including
the normal dial escape codes.
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Performing an Event Action on Set Condition
To receive an event alert for a specific condition:

1. Enter a nonzero value for state.

2. Enter a state event action with the same nonzero value when you
define the associated event actions that should be performed
conditionally.

Inserting, Deleting, and Reordering Event Definitions
Sensor parameters and event actions can be inserted, deleted, and
reordered with a simple button click.  The Insert button inserts an entry
before the currently selected entry.  The Delete button deletes the
currently selected entry.  The arrows at the bottom right of each pane
enable you to reorder the entries.

Inserting an Entry into an Existing List

To add to an existing list:

1. Select the line before the one where the new entry is to appear.

2. Select Insert.  The selected line moves down one line.

3. Enter the additional entry.

Deleting an Entry

To delete an entry in the list:

1. Select an entry.

2. Select Delete.

Reordering an Entry

To re-order the list:

1. Select an entry.

2. Select either the up arrow button or the down arrow button.  Use the
up or down arrow to reorder the selected entry.  Repeat to move the
selected entry to a position on the list.
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Saving Events Files
When you have completed the event definition, save it as a file for future
use.

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Save or Save As from the File pull-down menu.  The Save
dialog box displays.

3. Select an Events file name from the File Name pane, or enter a file
name in the File Name text box.

4. Select OK to save the file.

Macro Files
Macro files contain macro definitions.  These files are optional.  You can
use macros to define single or multiple actions that occur in an event or
a connection action.  With the Macro Definitions window, you can create
new and edit existing macros files that can be subsequently transferred to
a server. Refer to the file srvm.mcr or Macros File Example for examples
of a Macro file.

Creating A New Macros File
To create a new macros file:

1. Select Options from the menu bar.  The Options pull-down menu
displays.

2. Select Macros from the Options pull-down menu.  The Macros
submenu displays.

3. Select New from the submenu.

4. Choose the elements you wish to add to the new macro.
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Editing an Existing Macro File
To edit an existing macro file:

1. Select Options from the menu bar.  The Options pull-down menu
displays.

2. Select Macros from the Options pull-down menu.  The Macros
submenu displays.

3. Select Open from the submenu.

4. Enter the file name in the File Name text box, or select a macros file
name of the Macros file from the File Name box.

5. Select OK from the Open Macro dialog box.

The Macro Definitions window displays after you complete any of the
above procedures.  The window title bar displays the name of the file
being edited, or <unnamed_n> until you save a new file.  The Macro
Definitions window displays blank for a new file, or it displays the
macro name, action, and value for previously created macros.
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Figure 6-5 Macro Definitions Window
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Editing  Macro Names
Macros display in the Macro Name pane.

Creating a Macro

To create a macro:

1. Select <new macro> on the Macro definition window.

2. Enter a new macro name (up to 32 characters).

Editing a Macro

To edit a macro:

1. Select the macro you want to change from the Macro Name pane.

2. Enter a new macro name (up to 32 characters).

Defining Macro Actions
Use the Actions in a Selected Macro pane to define the specific macro
actions.
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Defining a New Macro Action

To add a macro action:

1. Select <new action> from the Macro Actions pane menu.  The <new
action> pull-down menu displays.

 Figure 6-6 Macro Action Window

 

2. Select a macro action.  It displays in the Action field.  RSM
automatically enters a default value for some macros.  If the default
value is incorrect, continue to step 3.

3. Select Value from the Macro Action pane, or enter the macro value
information.  Select the default value if one exists.  Another pull-
down menu displays.

4. Select the scroll arrow on the pull-down menu and select another
value.

Table 6-4 defines the values in a Macro Definition:
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Table 6-4 Macro Action Definitions

Action Description

Boot=type Do a boot or reset.  Type can be reset, cold, or warm.

Dialback Dial back to the management station.

Hangup Hang up the serial port.

Include=command Perform additional actions, as specified in the line starting
with the command in the Macros file.

Log with Tag=log Make a log entry with Tag 0-255.

Pause=pause Wait pause seconds before proceeding to the next action.
Pause=00-99 - 2-digit field.

Power=on-off Set power.  On-off can be on or off.

Retry=n Repeat the actions n times if a connection fails. n=0-99 - 2-
digit field.

Script=script Execute the script with the name script.

Send Alert Send an alert.  If the telephone line is unavailable, an event
alert is not sent.

Speed=baud Set the baud rate of the serial port to baud  300, 1200, 2400,
4800, 9600, 14400, 19200, 38400, or 57600 (default = 2400).

State=state Enter State.  State=0-255.

Stop on Failure?=yes-no Stop or continue subsequent actions if an action fails..
Yes=stop if an action fails.  No= continue with subsequent
actions if an action fails (default= Yes).

Stop on Success?=yes-no Stop or continue subsequent actions if an action succeeds.
Yes= stop if an action succeeds.  No=, continue with
subsequent actions if an action succeeds (default= No).

Telephone=number Set the telephone number.  Number is the number to be dialed,
including the normal dial escape codes.
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Inserting, Deleting, and Reordering Macro Actions
Macro actions can be inserted, deleted, and reordered with the Delete
and Insert buttons at the bottom of the Actions in Selected Macro pane.
The arrowheads in the bottom right corner of the Actions in Selected
Macro pane enable you to reorder your macro actions.

Inserting a Macro Name or Action into an Existing List
To add a macro into a list

1. Select the line before the one where you want to insert the macro
name.

2. Select Insert.

3. Enter the macro name.

Deleting a Macro Action
To delete a macro action:

1. Select the macro action you want to delete.

2. Select Delete.

Reordering a Macro Action
To re-order the macro list:

1. Select the macro action.

2. Select either the up arrow or the down arrow button move the action
one line up or down each time you select it.
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Saving Macro Files
Save the macro file after you have completed defining it.

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Save or Save As from the File pull-down menu.  The Save
dialog box displays.

3. Enter the file name in the File Name text box or select a macros file
from the Save dialog box.

4. Select OK from the Save dialog box.

Script Files
Script files contain communication dialogs that are used to make a
connection between a management station and a remote server, or to
send an event alert to a pager.  A script is a sequence of alternating
"expected input" and "next output to send" pairs that defines a dialog
over a serial port.

The RSM Scripts files contain multiple sub scripts.  Each sub script is
identified by a commented script name and consists of one or more steps.
You can add a new script file, or edit an existing one that can be
subsequently transferred to a remote server.

NOTE: If RSM sends event alerts to the management station, verify that
the correct scripts are being used for the modem installed on the remote
server and the management station.  An incorrect scripts file on the server
can cause the modem to remain in an unusable state.  To overcome this,
you may have to physically reset  the controller to its factory defaults.
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Adding and Changing Scripts

Creating A New Scripts File
To create a new script file:

1. Select Options from the menu bar.  The Options pull-down menu
displays.

2. Select Scripts from the Options pull-down menu.  The Scripts
submenu displays.

3. Select New from the submenu.

Editing an Existing Scripts File
To edit an existing script file:

1. Select Options from the menu bar.  The Options pull-down menu
displays.

2. Select Scripts from the Options pull-down menu.  The Scripts
submenu displays.

3. Select Open from the Scripts submenu.  The Open Script dialog box
displays.

4. Enter the file name in the File Name text box, or select a script file
name.

5. Select OK from the Open dialog box.
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The Script Definitions window displays after you complete any of the
these procedures.  The window title bar displays the name of the file
being edited, or <unnamed_n> until you save a new file.  The Script
Definitions window displays blank for a new file, and displays the scripts
name, step type, and value for previously created scripts.

Figure 6-7 Script Definitions
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Adding New Scripts to a Script
To add new script actions to a script:

1. Select <new name> from the Script Name pane.

2. Enter a new script name.  The script name can contain up to 32
characters.

3. The script name you are entering must be an existing file.

Inserting and Deleting Scripts Steps
Script steps can be inserted and deleted using the Delete and Insert
buttons at the bottom of the Script Name pane.

Inserting a Script Into an Existing Script Name List
To insert a step:

1. Select the line before the one where you want to insert the script
name.

2. Select Insert.

3. Enter the script name.

Deleting a Script
To delete a step:

1. Select a script name.

2. Select Delete.
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Defining Script Steps
The Steps in Selected Script pane lists the steps for a selected script.

Defining a New Script Step

To define a new step:

1. Choose <new step> from the Steps Type pane.  The Step Type pull-
down menu displays.

 Figure 6-8 : Defining New Script Step

 

2. Select a step type.  RSM displays the default value, <none>, for each
step.  Proceed to step 3 to add a new value.

3. Select <new value> from the Value pane.  Enter the Step Value
information.
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Table 6-5 summarizes the possible steps in a script definition:

Table 6-5 Scripting Steps

Step Description

Expect string Expect string.

Send string Send string.

Conditional
Expect string

If previous send failed, expect string.

Conditional Send
string

If previous expect failed, send string.

Abort string Abort the script.  Abort string causes the script
to abort if RSM receives string before the script
completes.

Timeout time Timeout time results in a wait of time seconds
in executing each step.  If the next step does not
arrive within time seconds, the script aborts.

Delay delay Delay pause seconds before proceeding to next
action. Pause=0-99 (2-digit field).

Parity parity Set the serial port parity Even parity (the
default), Odd parity, No parity, or set parity to
On.

Inserting, Deleting, and Reordering Script Steps
Script steps can be inserted, deleted, and reordered with the Delete and
Insert buttons at the bottom of the Steps in Selected Script pane. The
arrow buttons in the bottom right corner of the Steps in Selected Script
pane enable you to reorder steps.
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Inserting a Script Step
To insert a step:

1. Select the line before the one where you want to insert the script step.

2. Select Insert.

3. Enter the script step.

Deleting a Script Step
To delete a step:

1. Select a script step.

2. Select Delete.

Reordering a Script Step
To re-order steps in a script:

1. Select a script step.

2. Select either the up arrow button or the down arrow button.  To move
the item up or down one line with each click.

Saving Scripts Files
Save any new or changed scripts files for future use.

1. Select File from the menu bar.  The File pull-down menu displays.

2. Select Save or Save As from the pull-down menu.  The Save dialog
box displays.

3. Enter the file name in the File Name text box, or select a script file
name.

4. Select OK from the Save dialog box.
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Server Files
A server file contains summary server information.  Each server has its
own file with the server short name as the file name and an extension of
.sdf.  A server file contains the following information:

• Server's short name and long name

• Connection information

• Default file names for transfers

• Server status information

You can create and modify server files on the Setup window.  If RSM
cannot find any server files, it displays a warning message.  This
message displays the first time you use RSM, since you have not defined
any servers yet.

Server Log Files
The server log files contain time-stamped log files for each server.
Server log files have the extension .log.

The server log file is the only RSM file that can grow to any significant
size.  RSM adds each event to the server log file as it occurs.  This file
grows quickly if you define sensor parameters so that you receive many
events.  If you define sensor parameters so that you get only a few events,
this file will remain small.  Back up or delete any server log files to meet
the needs of your specific operation.
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Updating the Configuration Files
Once the edits are complete to the files, they will need to be re-loaded on
the server to take effect.  As with the installation initialization, you must
download these files to the remote server.

Transferring Files to the Remote Server
To download files to the remote server, use the Transfer window Default
File Names field to enter names for transferable configuration files and
memory.

Entering file names in this window is optional.  You can use the Setup
window to define default file names and gain efficiency when updating
multiple servers if you regularly transfer the same files or memory.

If files names are unknown, leave this window  blank until you plan to
use it or know the default file names to specify. Any file name you enter
as part of a transfer in the Transfers window also displays in this
window.

NOTE: This information is stored as files on the management station, but
on the servers, it is stored in a memory location.  You can transfer this
information from the files on the management station to server memory,
or from the server’s memory (except for the keystrokes) to files on the
management station.
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Figure 6-9 File Transfer Defaults

Transferring Server Files and Memory
The Transfer window is used to transfer configuration files and RSM
program files and RSM program files from your management station to
the remote server and from the remote server to the management station.

NOTE: Configuration files refer to the files needed to access
and control remote server monitoring and configuration.
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Figure 6-10 Selecting Files

To download files to the Remote server:

1. Select Transfers on the Control window.  The Transfers window
displays any file names you previously entered in the Setup window's
Default File Names for Transfers window. Otherwise, the RSM
default file names or <none> displays.

2. Select a file type.  Press Tab.  Select a file name or enter a file name.
(Press the CTRL key while selecting a series of file names to select
multiple files.)

3. Select "To Server" to transfer the selected files from the management
station to the server.  Select "From Server" to transfer selected files
and memory locations from the server to the management station.
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4. RSM transfers files in the order in which they display.  The file
name, its status, and the percentage of each file transferred also
displays. "Downloaded" or "Uploaded" displays after a successful file
transfer.

5. The "To Server" and "From Server" buttons change to "Abort"
during the transfer process.  To cancel a transfer, select the
appropriate (TO/FROM) "Abort" button during the transfer process.

6. Select "Close" after the transfer process completes.  The Transfers
window closes.

You must be connected to a remote server to make a transfer.  However,
you can enter file names in the Transfers window at any time.

RSM ensures each file exists and is valid (proper directory, opened by
other, and so on) before transferring it to or from a remote server.

NOTE: If you attempt to transfer an Event, Action Macro, Script, or
Security file larger than 2K to a server, RSM displays an error message
and does not transfer the file.

Transferring a blank Security file to a server disables RSM security.
RSM displays a warning message that transferring a blank security file
to a server enables all users to perform all RSM functions.  Therefore, to
enable RSM security, make sure at least one user has Administrator
privileges.

Defining a Default File Name
Scroll through the Transfer file list to find a file you want to transfer.
You can use the RSM default name or enter a different file name.

1. Select a file name.

2. Enter a file name, or select the arrow to the right.  The Enter file
name browser window displays.

3. Select a file name from the File Name window and select OK.  The
file name displays in the Default File Names for Transfers window.
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Changing the RSM Working Directory
If you create separate directories to keep track of each server file set, you
will want to change the directory that is used to transfer files.  This is
done by changing the RSM working directory.

1. Click on the RSM icon in the Program Manager window.  The RSM
menu displays.

2. Click on File from the menu bar.   The file pull-down menu displays.

3. Select Properties in the File pull-down menu (or press the ALT+F+P
keys).  The Program Item Properties dialog box displays.

4. Type the name of the directory that has the transferable files, and any
new files.  This is RSM's working directory.

5. Select OK or press Enter.

RSM will now transfer files to and from the stated directory.
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Troubleshooting A

This chapter summarizes problems that can occur and tips on how to
solve them.  Typical errors are often due to common file operation
errors, for example, when RSM cannot find a file due to a mistyped
filename or an incomplete path.

Fatal errors occur due to insufficient memory or failed internal program
consistency checks.  RSM notifies the users of the problem and exits.
Out-of-memory errors rarely occur on virtual memory operating systems.
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Startup Errors
RSM checks for the existence of application and user files each time it
starts.  It creates a default file if no user Preferences file exists.

RSM displays a warning immediately after installation if cannot find any
Server files.  Ignore this error unless you are re-installing RSM over an
older version.

Out-of-Disk-Space Error
RSM displays an error message and cancels the save if it encounters an
out-of-disk-space error during a save operation.  This can happen when
you save setup information and when you use Export and Print
commands.  You can switch to another application to delete some files or
clean up your disk, and then return to RSM to retry the save operation.

Any event alert that occurs when there is no available disk space on the
management station will be lost.
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Error Messages
The following error messages display for the reasons described:

• When attempting to transfer a file or memory location that requires
the server be in Held mode, RSM displays a warning message and
stops the transfer. Reset the remote server and set it into Held mode
to successfully transfer a CMOS setup or an EISA configuration.

• A warning message displays when downloading extended BIOS that
is in Held mode.  The server should not be in HELD mode.

• If you transfer a corrupt or incorrect EISA Configuration file to a
server and have inadvertently reset the server before correcting this,
you can recover by referring to the resetting the EBIOS Address.

• The size of the file can decrease if you transfer Event, Action
Macro, or Script files from a server. This is due to compression
and/or elimination of spaces, comments, and carriage returns.

• RSM remembers any abort or failure that occurs during a transfer.
A warning displays if you attempt to reset the firmware before
successfully completing a transfer.  RSM also remembers any abort
or failure that occurs during an EBIOS file transfer.  A warning also
displays if you attempt to reset the server before successfully
completing a transfer.
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 Troubleshooting Tips
 The following table provide troubleshooting tips for connection and
miscellaneous problems.

Problem Explanation Solution

You cannot connect to a
server via a telephone line at
startup even though the
Connection Status pane
displays the message "Script
executed without error."

All modem cables must
be connected before the
server's power is on.

Reattempt to connect to the
server via a telephone line.

If the server is accessible via a
LAN connection, re-boot the
server and then re-attempt to
connect via a telephone line.

If you still cannot connect to the
server, have someone at the
server site reset or power cycle
the controller.

At startup, you cannot
connect to a server via a
telephone line.  The
connection status pane
displays the message "No
serial port is available" when
you press Connect.

The flow control
setting for the COM
ports in Windows NT
Control Panel is None.

Change the flow control setting
to Hardware in the Ports section
of the Control panel.

Cannot connect to a server
via a telephone line
immediately after an event
alert arrives.  The message
"No serial port is available"
displays when you press
Connect.

The port is currently in
use.  It can take a
modem several seconds
to terminate a call.

Wait several seconds after an
event alert arrives before
pressing Connect.

CONTINUED



Troubleshooting

145

Problem Explanation Solution

You cannot connect to a
server via a telephone line.
The connection status pane
displays the message "No
serial port is available"
whenever you press Connect.

All serial ports are
currently in use.

The Port Manager did
not start or it exited
with an error.

The port is set up
incorrectly.

Use the Port Manager window to
verify the serial port is operating
in both originate and answer
modes.

If your modem has a DTR LED,
ensure that DTR is on.

If DTR is off, check the Port
Manager window for an exit
error message.

Verify the port's setup
parameters.

Event alerts do not arrive at
the management station
when there is a connection to
the server; event alerts arrive
when there is no connection.

The Default for a Stop
on Failure? action is
Yes.  When the server
already has a
connection to the
management station,
the script fails and the
event alert is not sent.

Insert a Stop on Failure? action
with No as the value in the script
before the Send Alert action.

Be sure that an Answer action
displays in the default.mcr file.

CONTINUED
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Problem Explanation Solution

 Event alerts do not arrive at
the management station
when there is no connection
to the server; event alerts
arrive when there is a
connection.

 The serial port is
operating in originate
mode only.

 The Port Manager is
not executing.

 Change the port setting to
operate in both originate and
answer modes.

 Insert answer in the Macros file.

 If you use a script, ensure that
the expect and send dialogs
match on both the management
station and the server.

 It can help to add \d as the first
command in the Script file for a
two-second delay.  This prevents
losing the management station's
initial response(s) during the
time the modem is setting up the
call.

 Start the Port Manager if it is not
executing.

 A modem does not work if
its power goes off and then
on again after RSM starts.

 The controller and the
modem can have
different default speed
settings.  RSM
initializes the modem
with the correct
settings when it starts.

 Set the modem's defaults to be
the same as the RSM settings.
RSM supports the modem
command,
AT&T0E0&C1&D2S0=1&W0
at 38400 bps.  This command
initializes the modem with the
correct defaults.  Refer to your
modem documentation for
specific information.

 Event monitoring does not
catch very short power
surges.

 The Event monitor
performs its checking
at 5 second intervals.

 Most power surges will cause
reboots if they are serious enough
and should be reported by that
event.

CONTINUED
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Problem Explanation Solution

 The server keyboard does not
function.

 The management station's
keyboard does not function
when the Console window is
the active window.

 The keyboard is not
connected to the
controller.

 -Or-

 The cable between the
controller and the
motherboard's
keyboard is not
connected.

 Check the two cables to ensure
that the connections are correct
and secure.

 Replace connectors.

 Reset the server if the server
beeps or does not function.

 Server log entries do not
appear in chronological
order.

 RSM uses the
controller clock.  The
clock has the wrong
time or the server is in
a different time zone.

 Synchronize the controller clock
with the management station's
clock.

 The Console window does
not display graphical images
that display on the server.

 Graphics modes are
not supported.
Graphical output
shows up as blanks in
the Console window.
The Console window
supports text mode
only.

 Modify server application or
disregard graphical output.

 The server cannot access the
management station's
diskettes.

 To use the Remote
Diskettes feature, the
server must be in BIOS
mode and the software
must support BIOS
diskette calls.

 Use Remote Diskettes feature
only when these conditions exist
on the server.

CONTINUED
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Problem Explanation Solution

 The server does not go into
Held mode.

 The Console window and the
Remote Diskettes feature do
not work.

 The extended BIOS is
not loaded or it has
been corrupted.

 Ensure that the EISA
Configuration utility has been
run and the controller has a valid
BIOS address.

 Transfer the Extended BIOS file
from the management station to
the server, reboot, and then retry.

 RSM sends many voltage log
entries and/or event alerts
when the server's power is
turned off.

 Voltage log entries
and/or event alerts
have been defined for
low voltage readings
that normally occur
when the server's
power is being turned
off.

 Insert a State variable in the
Events file before all voltage
monitoring.  Check whether the
Server's Mode is Power Off and
then change the State value so
that RSM does not generate log
entries or event alerts when the
server's power is turned off.
Refer to Appendix B, File
Examples, for examples of these
files.

 MS-DOS hangs when you
transfer an Extended BIOS
file to the server while MS-
DOS is booting.

 An Extended BIOS file
cannot be transferred
to a server while MS-
DOS is booting.

 Wait until MS-DOS has finished
booting before transferring an
Extended BIOS file to the server.

CONTINUED
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Problem Explanation Solution

 After transfering an
Extended BIOS file to a
server immediately after
resetting it, the message
"Error reading EISA
configuration data.
Download setup failure."
displays.

 The address of the
Extended BIOS is
unknown because the
BIOS did not complete
EISA initialization.

 After resetting a server, wait
about 30 seconds before
transferring an Extended BIOS
file to the server.  This allows
time for the EISA initialization
to complete.

 Modem defaults to initial
factory settings.

 Modem has not saved
settings to NVRAM.

 Save settings to NVRAM.  Some
modems do not permit
information be saved to
NVRAM.   One known modem
is the Diamond Supra Express
56K.
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Sample Configuration Files B
 This appendix displays sample ascii text files that are the underlying
files behind the configurations discussed in Chapter 6.  The files shown
here are the default files included with your original installation kit,
unless otherwise noted.  All of these files are found in the RM_MGR of
the RSM application.

 The following files are listed:

• Event File

• Macros File

• Alert Scripts

• Scripts
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Event File Examples
Example1.evt is an example of an Events file. Example1.evt is similar to
the following events file:

EVENT

# This is an example of an Events file.

# It monitors the following sensors:

# Controller initialization (or power up).

# Server reset.

# Server +5V (or power off).

# Monitor server temperature and send an event alert if the temperature
is outside 40 # to 104 degrees Fahrenheit.

# Monitor server keyboard for keystrokes.

#State Entry Comparison Value Action1 Action2

#------ ------- -------------- -------- --------- ----------

0 server_mode = = init include=alert_ms

0 server_mode = = reset log=1 include=alert_ms

0 v_5 outside 47,53 log=10 include=alert_sec

0 temperature outside 40,104 log=20 include=alert_dbl

0 keystrokes > 0 log=60 include=alert_sec
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Macros File Example
RSM uses these macros files to connect a management station to a
remote server.  The following is a sample srvm.mcr file:

# This is the Remote Server Manager's Macros
file. Change as needed to specify your server
environment. Uncomment the advanced features you
want to use. (Remove the # notation).
# Transfer this file to a server as part of
setting up a new server
# or whenever the server environment changes.

# (This file specifies an ATT Dataport modem and
a speed of 38400.)
connect speed=38400  \

script=att_dp

# Example of how to setup dialback:
#  dialback \
# telephone=99999 \
# include=connect dialback

# Example of how to setup event alerts:
# The controller sends an event alert to a
management station with a port with
# telephone number 99999.
# The port must be specified with Answer as a
Port option on the
# management station.
ms1 \

telephone=99999 \
include=connect

# Example of how to set up event alerts with two
telephone numbers:
# This is useful with multiple telephone lines if
the first telephone number is busy.
ms2 \

telephone=99999 \
include=connect
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Alert Scripts Examples
This is a sample svrm.evt file.

# Example of sending an alert:

# (The server can be connected or not connected
to the management station
# at the time the controller sends the alert.)
alert_ms stop_on_success=yes stop_on_failure=no \
alert stop_on_failure=yes stop_on_success=no
include=ms1 alert
# Example of sending an alert:

# (The server is not connected to the management
station.  If the first
# telephone number is busy (ms1), the controller
tries to connect via the
# second telephone number (ms2).)
alert_dbl stop_on_success=yes stop_on_failure=no
alert \
stop_on_success=no include=ms1
stop_on_success=yes alert stop_on_success=no
include=md_hup \
stop_on_failure=yes include=ms2  alert

# Example of sending an alert with a login type
of script:
# (See example1.scr file for login script.)
alert_sec stop_on_success=yes stop_on_failure=no
alert \
stop_on_failure=yes stop_on_success=no
include=ms1 script=login alert

# Example of sending an alert with retries every
minute if modem connection fails:
# (The maximum is specified to be 20 retries.)
alert_retry stop_on_success=yes
stop_on_failure=no alert \
stop_on_failure=yes stop_on_success=no retry=20
include=ms1 retry=0 alert
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Scripts File Example
Example1.scr is a Scripts file in your RSM directory.  Example1.scr is
similar to the following Scripts file example:

# NOTE: Most full modem cables have pins 8 and 6 connected to
each other at both ends of the cable.  This will not cause a problem for
direct connection.

# Direct connection script: direct "" P_ZERO
# Servers with user name and password security:
login "" P_ZERO ogin:--ogin: user_name word:
pass_word
login "" P_ZERO ogin:--ogin: user_name word:
pass_word
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Getting Paged by RSM C
Pager Notification Feature

The pager feature allows the server to send call a pager when an event
occurs while the server’s modem is not in the “CONNECT” state or an
Off Hook condition exists.  RSM does not currently support alpha
numeric pagers.

The Pager setup requires you to modify scripts, macros, and events to
function.  These files are then downloaded to the RSM card.

The event file contains an event that is associated to an action.  When
the condition changes to trigger the action, it calls a macro file that will
setup the Success/Fail conditions for connecting.  This macro file will
then call a second macro file that will set up the RSM port speed to
38400 bps and call a modem script file to complete the cycle.
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The easiest way to test the paging scripts is to associate a system reset to
activate the pager.

NOTE: Using the “ Keystroke > xx" option will only compare the
value to the system keyboard buffer count 1 time until the system is
reset and the system keyboard buffer is cleared

Setting up the Pager
Select the .scr file related to the specific server that will want to page the
responsible party.

1. Select "Options" from the Toolbar.

2. Select Script from the Options drop-down menu.

3. Select Open from Script drop-down menu.

4. Select “xxxFilex.SCR”.

NOTE: When testing, it is advisable to save the srvm.scr, srvm.mcr,
and srvm.evt files to other files to prevent losing all current attribute
settings. Upon successful testing, you can rename the files back and
download if you so desire.

If you are not sure of the name of the .scr file name:

1. Select Functions from the toolbar.

2. Select Transfers to/from from the Functions pull-down menu.  The
screen that displays will show the names of the currently downloaded
files on the server.

3. Identify the modem script and copy the attributes to a new script
named for example [pager]. Keep the name lower case to avoid
confusion.
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In the pager modem script, change the following values:

• <TIMEOUT  90>

• Delete the second TIMEOUT entry

• Change the last Expect from CONNECT to BUSY  <EXPECT
BUSY>

• Another way to create this macro is to edit the xxxx.SCR file, which
is located in the RS_MGR directory, then copying and pasting the
modem lines.

Review the following Pager setup example, substituting your filenames
for the scripts and macros.

Pager Setup Screen Examples
The following shows how the appropriate screens will display when
setting up the pager feature.  Modifications will be made to events,
macros and scripts.  The last step is to download the files to the RSM
controller.

1. The event will be a [System Reset].  The reset will trigger an event in
the event file that will call the [alert_ms] macro.

2. The [alert_ms] macro sets up the success / fail procedure options,
sends an event alert to the management station, and calls a second
macro [ms1].

3. In turn, the [ms1] macro sets the Pager telephone number, and calls a
new macro [skypage].

4. The [skypage] macro sets the RSM port speed to 38400 and calls the
new modified modem script [pager]

5. The [pager] script sends the dialer string to the modem for
connection and message transfer.  It then identifies an event for
paging and assigns one action.  It finally calls the alert_ms macro.

6. Selecting Server Mode - Reset, as shown in the Event Definitions
screen (Figure C-1), will trigger the event to send a page.  This
screen also assigns the action of calling the [alert_ms] macro.
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Figure C-1 Event File for Paging
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Figure C-2 shows the alert_ms macro setting up the Success/Fail options
and then calls a second macro, [ms1], prior to sending an alert.

Figure C-2 Paging Alert Macro
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Figure C-3 shows macro [ms1].  It sets up the pager telephone number
and message as well as the call to the Skypage macro.

Two actions are assigned on the following screen:

• Speed 38400 (This speed should be used regardless of the modem
speed)

• Call to the Pager macro file

Figure C-3 Adding Pager Telephone Number
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Figure C-4 show the attributes for the Modem Script (Zoom).  Select the
modem script name, Pager, and copy the attributes from the Zoom macro
file from this screen.

Figure C-4 Zoom Macro for Paging

The script requires that when the modem sends the telephone number
string, it will expect a “Busy” response from the modem.  If the default
modem string is used, the modem waits for “connect,” which is never
received.  It then waits to timeout, and then redials.

From this screen, download the following files:

xxxx.EVT
xxxx.MCR
xxxx.SCR

Once the files have successfully downloaded, disconnect the server and
test for paging.
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